0

I have got a clean build (WordPress 3.9.1 running Twenty Fourteen theme).

I've installed WooCommerce plugin and added one product.

The product is a variable product with 65 variations.

When I link all variations and save, there are no issues. But editing any information such as stock quantities or price etc and hitting Update will cause the problem below.

Once I click Update, I am redirected to edit.php (the Posts page) and the changes were not saved. There is no error and everything seems to be running just fine.

Upon removing variations one by one I realised that once there's less than 50, the post updates perfectly.

I've tried increasing memory in PHP.ini, .htaccess, wp-config.php and nothing.

Any ideas at all as I'm absolutely lost on this one.

Many thanks in advance.

Michael

EDIT: In actual fact, you don't have to even attempt to change the properties of the new product. Even just trying to change this as it is will cause this issue.

18
  • Try deactivating all plugins. If that works perfectly, then it's because of some plugin, which is off topic here: help center Jun 17, 2014 at 14:49
  • The only plugin that's installed is the WooCommerce one. I've recreated this issue with a brand new install. I have a funny feeling it's to do with Wordpress set up though. Jun 17, 2014 at 14:53
  • Try to save a post after deactivating woocommerce. Jun 17, 2014 at 14:55
  • WooCommerce uses a 'Products' as a custom post type. If I deactivate it then I won't be able to edit the post...? Jun 17, 2014 at 14:58
  • Try increasing post_max_size in your PHP ini Jun 17, 2014 at 14:59

2 Answers 2

2

For anyone who might still be looking for an answer on this 6 years later. I recently just had a similar issue and found the culprit to be the file limit of my hosting account had been exceeded. There was no error or anything from Wordpress I was just knocked back to the posts page. Clearing an old backup to free some space immediately resolved this issue for me.

1

For anyone looking for an answer on this, I found that setting the max_allowed_packets to 32 helped as well as turning off mod security on the host side. I hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.