0

I enabled ssl connection on my wordpress website. From Admin panel → settings → and changed both URL from http to https.

Then added

define('FORCE_SSL_ADMIN', TRUE);


if (isset($_SERVER['HTTP_X_FORWARDED_PROTO']) && $_SERVER['HTTP_X_FORWARDED_PROTO'] == 'https')
            $_SERVER['HTTPS']='on';

to my wp-config.php file. But it's about 4 days any now while try to load it first page is give the error about unknown certificate.

Then must click on continue anyway to load it, after the loading my HTTPS is in the red color with the crossed. Please help me how can I fix it

I think my WordPress site need a certificate.ctr file that I must create it and upload in the wordpress root, but I don't know how to do it?

migrated from superuser.com Jun 9 '14 at 4:57

This question came from our site for computer enthusiasts and power users.

  • Before configuring WordPress to use HTTPS, did you.... (1) purchase an SSL certificate, (2) configure the CSR, (3) submit the CSR, (4) approve the SSL certificate, and then (5) install and enable the certificate you received on to your server? These are all things you need to do before you can use HTTPS for your website. – iglvzx Jun 9 '14 at 5:00
  • The OP may be using an SSL certificate provided by their hosting company. Mine has this so I don't need to configure anything. You also need to upload your WordPress site to the correct folder on your hosting. Many hosts have a separate htdocs for SSL enabled sites. – Kinnectus Jun 9 '14 at 6:25

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.