6

The soundcloud short code does not seem to be working. I've tried over several days and it just shows up as raw code. Is this a glitch, has support officially been discontinued, is there some workaround?

[soundcloud url="https://api.soundcloud.com/tracks/151458437" params="color=ff5500&auto_play=false&hide_related=false&show_artwork=true&show_comments=true&show_user=true&show_reposts=false" width="100%" height="166" iframe="true" /]

https://soundcloud.com/radhanath-swami/offer-the-best-you-have

Using the latest wordpress 3.9.1

  • 1
    Are you talking about wordpress.COM or a self-hosted version from wordpress.ORG ? Also - have you tried not using this api.soundlcoud.com URL but soundcloud.com/radhanath-swami/offer-the-best-you-have ? – kraftner Jun 5 '14 at 13:38
  • 1
    Not on wordpress.com but for a domain which i am still testing on my localhost. I pasted the embed code from soundcloud in a post – Santhosh Yedidi Jun 5 '14 at 14:03
4

If you are on WordPress 3.5 or higher just putting the URL on a separate line should work:

https://soundcloud.com/radhanath-swami/offer-the-best-you-have

You do not need to use the embed code, WordPress handles the embedding via oEmbed itself.

Also have a look at the Codex.

EDIT: If you want the small image you probably should have mentioned that in the question...

The easiest way probably is to put the embed code in

<iframe width="100%" height="166" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/151456970&amp;color=ff5500&amp;auto_play=false&amp;hide_related=false&amp;show_artwork=true&amp;show_comments=true&amp;show_user=true&amp;show_reposts=false"></iframe>
  • it worked, but it shows big image. what to do for small image – Santhosh Yedidi Jun 5 '14 at 15:04
  • I just updated the answer... – kraftner Jun 5 '14 at 16:26
3

Self-hosted WordPress core code simply doesn't have such shortcode. It's extra addition at wordpress com service.

While oembeds (using soundcloud URL alone) work fine with it, there is no shortcode to customize it. You would need to add custom code for it or research for a plugin that implements such shortcode.

  • instead of using the soundcloud url, can the embedded code from sound cloud be used so that is shows smaller icon than big one. – Santhosh Yedidi Jun 5 '14 at 15:15
  • @SanthoshYedidi If by "embedded code" you mean example code you had shown in question — then no. That would only work on wordpress.com site. – Rarst Jun 5 '14 at 15:16
  • what about other websites. Also only wordpress can use wordpress.com what about others – Santhosh Yedidi Jun 5 '14 at 15:26
3

The "Wordpress code" checkbox on the soundcloud embed screen is for Wordpress.com users only. If you have a self-hosted (Wordpress.org) site, leave "Wordpress code" unchecked and copy the <iframe> code. Paste that into the HTML view of your wordpress page. Voila!

2

Not sure why Roland's comment is marked down because using Jetpack with it's "Shortcode embeds" setting turned on makes the embed code work.

I have just been using a theme with the latest version of WP 4 and the SoundCloud shortcode only worked once I activated Jetpack Shortcode Embeds.

0

add this to your functions.php

// Add SoundCloud oEmbed
function add_oembed_soundcloud(){
wp_oembed_add_provider( 'http://soundcloud.com/*', 'http://soundcloud.com/oembed' );
}
add_action('init','add_oembed_soundcloud');

Source: How to Embed SoundCloud in your WordPress Posts by using oEmbed

just make sure its inside <?php ?>

  • so after doing this the embed code will work. – Santhosh Yedidi Jun 5 '14 at 14:04
  • Yes it should work. – H3r0k0 Jun 5 '14 at 14:12
  • Did u, by any change, forgot to mention a plugin is required? – ericn Jul 16 '15 at 8:57
0

I spent way too long trying to figure this out and finally found it, so posting here. If you want the large square player, you can simply paste the Soundcloud URL on a separate line - like Rarst says. For example:

https://soundcloud.com/user-426955691/episode-1-about-the-chat

Embedding the smaller player is trickier, and I couldn't find a concise answer.

First, from Souncloud:

  1. Click the Share link on the post.
  2. Click the embed tab on the popup
  3. Highlight the smaller player to see the small player embed code. It will look like this.

WordPress will not let you drop the <iframe> into the editor. It seems to be for a security reason. I downloaded a plugin called iframe. With this plugin, you can add an <iframe> tag to the content. Simply change < and > characters in the <iframe> tag to brackets, [ ], e.g. [iframe].

Once you activate the iframe plugin. So simply drop this code into the page edit screen in WordPress.

[iframe width="100%" height="166" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/304567138&amp;color=ff5500&amp;auto_play=false&amp;hide_related=false&amp;show_comments=true&amp;show_user=true&amp;show_reposts=false"][/iframe]

-2

Just use the Jetpack plugin. In Settings activate the "Shortcode Embeds" function.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.