0

i've arranged my new Server and i use proFTPD with TLS Support. Now, WordPress can't upgrade or install plugins anymore.

I get the following message: The directory "wp-content" cannot be found

This is my FTP(S) Setup at wp-config.php:

/** FTP */
define( 'FS_METHOD', 'ftpext' );
define( 'FTP_USER', 'username' );
define( 'FTP_PASS', 'password' );
define( 'FTP_HOST', 'example.com' );
define( 'FTP_SSL', true );

EDIT: previously i have defined the following constants to prevent this bug:

define('CONCATENATE_SCRIPTS', false);
putenv('TMPDIR='. $_SERVER['DOCUMENT_ROOT'] .'/wp-content/tmp');
define('WP_TEMP_DIR', ABSPATH . 'wp-content/tmp');

.. but that doesn't work anymore.

2
  • How about permissions? Do the user have appropriate permissions to view/edit wp-content directory and its sub-directories?
    – sri
    May 28 '14 at 10:01
  • every directory has the user:group permissions and every directory directory has the 755 permission.
    – hazelnut
    May 28 '14 at 10:03
0

I found the solution! I had to add a new tls option at the proftpd configuration and delete all files. Now i have uploaded the files once again and it works now. :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.