I'm having a serious problem with the plugin Custom Field Template in which applying a CFT based on the template name is not working (it's as if the Ajax used to load the template is breaking). I've tried getting help in the forums but no response - seems to be browser independent (tried it in FF4, Safari 5 and Chrome).

I need to find out why this is happening and I'm running out of time as my client needs to go live with this site by the end of the week they say.


Can someone take a look at the video above and let me know what I could do to try and solve the issue? It's a great plugin, but this kind of issue reaffirms why it's always best to not use plugins if possible :(

Any help massively appreciated,


3 Answers 3


This Plugin is loading quite a lot of scripts:

wp_enqueue_script( 'jquery' );
wp_enqueue_script( 'jquery-form' );
wp_enqueue_script( 'date', '/' . PLUGINDIR . '/' . $plugin_dir . '/js/date.js', array('jquery') );
wp_enqueue_script( 'bgiframe', '/' . PLUGINDIR . '/' . $plugin_dir . '/js/jquery.bgiframe.js', array('jquery') ) ;
wp_enqueue_script( 'datePicker', '/' . PLUGINDIR . '/' . $plugin_dir . '/js/jquery.datePicker.js', array('jquery') );
wp_enqueue_script( 'textarearesizer', '/' . PLUGINDIR . '/' . $plugin_dir . '/js/jquery.textarearesizer.js', array('jquery') );
if( strstr($_SERVER['REQUEST_URI'], 'wp-admin/post-new.php') || strstr($_SERVER['REQUEST_URI'], 'wp-admin/post.php') || strstr($_SERVER['REQUEST_URI'], 'wp-admin/page-new.php') || strstr($_SERVER['REQUEST_URI'], 'wp-admin/page.php') || $post->post_type=='page' ) :
    wp_enqueue_script( 'editor' );

It's possible that there's a conflict.

Are you sure the issue began with WordPress 3.1.1, rather than with 3.1? The jQuery version in 3.1 was bumped up; I'm unaware of any script version changes in 3.1.1, but I could be wrong.

  • It's quite possible there's a conflict and to be honest, Im not 100% sure if it's a 3.1 or 3.1.1 issue so I'll try a fresh install with 3.1 and compare it to 3.1.1 to check (will report back once I've done that). If it is a script conflict, what's the best way to check that out? With Firebug? I've been in contact with the plugin developer but no heard back for a while now from him so I'm assuming it's a bit more of a complex issue than I anticipated
    – Osu
    Apr 13, 2011 at 6:04
  • I've just tried it on a 3.0.5 and 3.1 install and same thing :( I'm guessing there might be an issue with the Templates I've set up so I'll look at that next unless you can suggest something else I can try?
    – Osu
    Apr 13, 2011 at 7:17

I know it's more than a year later, but it seems the conflict between Custom Field Template v2.02 and Ajax Event Calendar v1.02 continues to exist.

The solution recommended on many blogs/forums is to delete the date.js file from the /wp-content/plugins/custom-field-template/ folder - However, this leaves "Custom Field Template" unable to use the date-picker on any fields.

I've posted an alternative solution here which allows both plug-ins co-exist and function without an hindrances:


  • I ended up going with Advanced Custom Fields by Elliot Condon - much better plugin IMO. advancedcustomfields.com
    – Osu
    Apr 16, 2012 at 9:11

This issue seems to have been fixed in Custom Field Template 1.8.5 :


Thanks for the responses @Chip Bennett!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.