0

I am the webmaster of the German WordPress website http://www.kunstplaza.de.

Recently, I have noticed that there are no items in the RSS feed, although there should be some as I am posting new articles on a regular basis.

The Feed URL is: http://www.kunstplaza.de/feed/

As far as I remember, this feed did work in the past. I have already deactivated all plugins and themes (one by one) and tried to retrieve the feed after that. Unfortunately, this did not have an effect. Only when I rename the "plugins"-folder, the feed starts to show up.

In the error log of my hosting provider I have found this line quite some times:

[error] You have an error in your SQL syntax; check the manual that corresponds to your       MySQL server version for the right syntax to use near ']posts.ID NOT IN ( )  ORDER BY wp_posts.post_date DESC' at line 1 f\xc3\xbcr Abfrage SELECT   wp_posts.* FROM wp_posts  WHERE 1=1  AND (wp_posts.ID = '296') AND wp_posts.post_type = 'page' AND $wpdb-]posts.ID NOT IN ( )  ORDER BY wp_posts.post_date DESC  von require('wp-blog-header.php'), wp, WP-]main, WP-]query_posts, WP_Query-]query, WP_Query-]get_posts, W3_Db-]query, W3_DbCache-]query, W3_DbCallUnderlying-]query, W3_Db-]query, W3_DbProcessor-]query, W3_Db-]default_query

I guess, this is the error that blocks the RSS feed from working in a correct way. It seems as if the W3Cache Plugin is causing this issue. I have already deleted the whole plugin and reinstalled it from scratch. This did not solve the issue. I am using this plugin on other sites with the same configuration without having any problems.

I guess, the database needs to be repaired somehow. Unfortunately, as I am not a programmer, I do not have an idea of where to start or which db tables could be involved.

Does somebody of you have a clue? What could be a potential source of this issue?

Thanks a lot for your feedback!

  • Have you tried deactivating all plugins except for W3 cache? If so, did you get the same error? – TheDeadMedic May 21 '14 at 10:14
  • Thanks for your reply! I have done as you suggested. With only the W3 Cache Plugin activated the feed does work. – Jazzy Joe Jun 11 '14 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.