0

I'm trying to set up a new blog on my company website and blog posts are not showing up as subpages to the blog page.

I would like for the url to all blog posts to read:

techmdinc.com/blog/post-title

How do I go about making this happen? Do I need to do it manually?

  • 2
    Is WordPress powering the main site or just the blog area? – jdm2112 May 20 '14 at 20:22
  • The whole site. – user51928 May 20 '14 at 21:15
0

Set your permalink structure to:

/blog/%postname%/

This won't affect the URL's for pages, but will prepend blog to your category & post tag permalinks (unless you have set a category/post tag base, also on the permalinks setting page).

  • This won't affect non-blog pages? – user51928 May 20 '14 at 21:15
  • Woops, typo. I meant "pages" not "permalinks" (answer edited). So in answer to your question, no it won't affect them :) – TheDeadMedic May 20 '14 at 21:27
  • This would be on each individual page, right? Sorry, wordpress kind of bends my brain. – user51928 May 20 '14 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.