0

Hoping someone can help me troubleshoot my White Screen of Death.

Site Info:

  • WP 3.9.1 (just upgraded)
  • PHP Version: 5.4 (just upgraded)
  • Single Version
  • Many other installs of WP on this server (with same database / php settings) and they are unaffected.
  • I was prompted to do the 'Update Database Required' on wp-admin when I first had the issue and I did.
  • I CAN log into wp-admin and content is there in the backend working fine with no issue
  • All Plugins disabled.

What I've done so far:

  1. Check version with version.php and database values

    • wp_db_version = 27916 (matches database)
    • Also checked 'home' and 'siturl' to see if they have the correct url—they do
  2. Disabled plugins (renamed plugins folder to plugins.hold)

    • After renaming this the site generated a code about wp-super-cache error
    • After error, I added a new plugins folder > and downloaded most recent version of the plugin and installed manually
    • Error message went away, but still WSOD no html generated
    • I set the 'active_plugins' value to 'a:0:{}' in database
  3. Deleted custom theme, should be referencing twentyfourteen

  4. Manually replaced wordpress base files

  5. Tried error reporting on wp-config—no reports generated, still WSOD

I'm out of ideas, don't know what else to even search for—and since I can't get error reporting to show anything, I'm at a roadblock.

  • white screens of death are when error reporting is not set to display errors. Find your error log or enable error reporting – Tom J Nowell May 19 '14 at 15:57
  • When you say "should be referencing twentyfourteen", did you actually activate it in the admin? Otherwise WP will just bail on the front-end if the active theme isn't there. – TheDeadMedic May 19 '14 at 15:58
  • @TheDeadMedic please add this as an answer so you get some points. And send me your address—you get a box of cookies. – RooWM May 19 '14 at 16:15
1

You need to activate the default theme in the admin; WordPress will just bail on the front-end if the active theme isn't on the filesystem (it won't fallback to the default automatically).

1

Did you try:

  • Thanks, I've now tried increasing the limit—no avail. I've emailed the hosting company about whether or not there is a block / set value on the server for PHP Memory Limit as I cannot find it in the CPanel. – RooWM May 19 '14 at 16:01
  • Where do you suggest adding the PHP error reporting code on the link you provided? Tried a few places like root index file—no luck. – RooWM May 19 '14 at 16:02
  • add it in wp-config.php, right before it says to stop editing – pdme May 19 '14 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.