0

Whenever I try to access pages within my site, such as mysite.com/wp-login.php, it redirects to mysite.com. It doesn't redirect if I put www.mysite.com, however. Is this a domain configuration issue, or a WordPress issue?

3
  • Check your .htaccess file in the wp root (or below) dir.
    – kaiser
    Commented May 16, 2014 at 2:12
  • I don't see one anywhere.
    – muttley91
    Commented May 16, 2014 at 3:37
  • What changed to cause this behavior? That will be your best starting point for debug.
    – jdm2112
    Commented May 16, 2014 at 3:47

2 Answers 2

1

Another possibility is that you haven't generated permalinks/a proper .htaccess file for your site. From within Wordpress, go to Settings > Permalinks, and update/save your link structure. See if that helps.

0

Try this I think it should work for you

http://example.com/your-sub-dir/wp-login.php

I had a similar problem where I couldn't login it looks like you're just missing the your-sub-dir part in the URl. I think the problem may be in your wp-login.php file if that gets you into admin great if not let me know and I'll give you a few more ways you can try to get in.

If you can get in try this. Go to the case retrievepassword section, found under this comment:

// redefining user_login ensures we return the right case in the email
// Replace: 
$user_login = $user_data["user_login"];

// With: 
$user_login = $user_data->user_login;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.