0

I have installed Wordpress 3.9.1 on wampserver2.2e-php5.3.13-httpd2.2.22-mysql5.5.24-x64. Then I installed the Facebook Plugin (1.5.5). I created a Facebook app and than I wanted to enter the credentials in the Facebook plugin. I get the following error message:

Your server does not support communication with Facebook servers over HTTPS.

Facebook application functionality such as posting to your Facebook Timeline requires a HTTPS connection to Facebook servers

What can I do to allow the HTTPS connection? Is this a configuration problem with wampserver?

PS: I don't know where to put this topic. Is it serverfault, superuser or wordpress? I put it on wordpress because it is the main topic here.

Edit:
The error message is thrown through this piece of code:

// notify of lack of HTTPS
if ( ! wp_http_supports( array( 'ssl' => true ) ) )
    add_action( 'admin_notices', array( 'Facebook_Application_Settings', 'admin_notice' ) );
1

I imagine this is because php_curl extension hasn't been enabled in wamp. You can try to enable curl and then restart wamp.

If you have a tray icon for wamp you can left click on the tray icon, choose PHP -> PHP Extensions and enable php_curl. Then left click the icon again and this time select Restart All Services.

Or to do it manually:

  1. Navigate to WAMP\bin\php(your version of php)\
  2. Edit php.ini
  3. Search for curl, uncomment extension=php_curl.dll
  4. Navigate to WAMP\bin\Apache(your version of apache)\bin\
  5. Edit php.ini
  6. Search for curl, uncomment extension=php_curl.dll
  7. Save both
  8. Restart WAMP
  • I tried both ways but the error message still exists. Do you have more ideas? – testing May 12 '14 at 22:25
0

The problem was in fact that curl was not loaded. Instead something like WP_HTTP_streams was used. But it seems that the curl dll for Windows delivered with the package needs to be fixed. I used the information from this thread:

  1. Setup wamp.
  2. From wamp icon select PHP > PHP extensions > php_curl (it needs to be checked)
  3. Extract php_curl.dll from the zip and copy it to PHP extension directory (mine is c:\wamp\bin\php\php5.3.13\ext)
  4. Restart all services from the wamp menu
  5. Go to localhost and click phpinfo() link and see that curl is there…

You can download the zip file (php_curl-5.3.13-VC9-x64.zip) from here. Now everything is working fine and curl is also available in the phpinfo (localhost/?phpinfo=1).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.