0

I just rebuilt my server with Ubuntu 14.04, Nginx 1.6.0, PHP 5.5.9 and Wordpress 3.9. I am able to complete the Wordpress install and login to the Wordpress dashboard, however, I can't make any changes. If I try and delete a post, Wordpress says the action is completed, but when I hit the Posts menu again, the post comes back. If I try and create a post, Wordpress says the action is complete, but when I hit the Posts menu option, it disappears from the table.

What's even more weird is if I wait a couple seconds and press the Posts menu option again (to refresh the Posts table) my changes will be there - but it doesn't always happen.

This problem exists all throughout the Dashboard and I'm starting to wonder if there's an issue with Wordpress and PHP 5.5.9 since it looks like the PHP team incorporated some caching capability.

My same setup works on Ubuntu 13.04, Nginx 1.4.6, PHP 5.4.9 and Wordpress 3.9.

I haven't made changes to the default php.ini file and I installed php using

sudo apt-get install php5-cli php5-cgi psmisc spawn-fcgi

I'm using MySQL as the database and I connected PHP to MySQL using

sudo apt-get install php5-mysql

My database user has all permissions on the appropriate database.

I'm also wondering if there's something in my Nginx Virtual Hosts file for the site that would cause this issue.

8
  • Can you check your server logs?
    – s_ha_dum
    May 4, 2014 at 17:44
  • Is the Opcache actually enabled in your php.ini? By default it isn’t.
    – fuxia
    May 4, 2014 at 17:47
  • take a look at your database and see if posts are truly being added in the posts table. From there you may be able to narrow down if it is a caching issue May 4, 2014 at 17:51
  • @Douglas I created a post and then looked at the MySQL posts table - the post is created immediately. However, it doesn't show up in the wordpress dashboard Posts table. I closed down the browser, cleared my cache and logged back into Wordpress and the post now appears.
    – CodeSmith
    May 4, 2014 at 18:04
  • @s_ha_dum I cleared out my logs and tried to create a post. No errors are being generated.
    – CodeSmith
    May 4, 2014 at 18:06

1 Answer 1

1

I was finally able to get this to work by using php5-fpm instead of php5-cgi. First I removed the php5-cgi package via

sudo apt-get autoremove --purge php5-cgi

Then I installed php5-fpm via:

sudo apt-get install php5-fpm

After tweaking my server definition in Nginx a bit, the problem went away.

Update I suspect this had more to do with a faulty Virtual Host file for my website then php5-cgi.

1
  • Thanks for keeping the site constructive and posting your solution. +1 May 5, 2014 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.