I have created a custom post type called 'members' which works correctly. I have set the rewrite rule to...

'rewrite' => array('slug' => 'our-members'),

I have then added some items to this custom post type which gives me permalinks like so...


I also have a page called 'About Members' which has the slug 'about-members' meaning the permalink for the page is....


This doesn't work as it is clashing with the rewrite rule, is there a way to have this working with the permalink?

  • 1
    Can't the page just be mydomain.com/about-members instead? – Steven Jones May 1 '14 at 15:32
  • I had this issue recently with custom post types, the reason why WordPress allows that slug between the url and the post name is to prevent clashes like this. Normally a regular page should just be url/title - did you just apply a re-write to the custom post type and not the standard urls? This is assuming that your permalinks in Settings (dashboard) is set to Custom Structure or Post Name and your "About Members" page is a normal WP Page. – RachieVee May 1 '14 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.