0

I am pretty new to wp. I have installed wp 3.9 on a demo site. I wanted to configure and add some plugins; eg the

  • facebook
  • wp-rss-multi-importer

I've noticed that I cannot do some configurations with the widgets

Reference: Wordpress Widgets

They can be added, removed, and rearranged on the WordPress Administration Appearance > Widgets panel.the order and placement is set by the WordPress Theme in the functions.php file. Some WordPress Widgets offer customization and options such as forms to fill out, includes or excludes of data and information, optional images, and other customization features.

on the page where I can configure the widgets I cannot get anything done.

I cannot add widgets and I do not know why.

btw: some friends mentioned that I have issues with jquery.

Any suggestions to what might be wrong

update: have deactivated all plugins and switched back the theme to twentyfourteen. but nothing happppened - all those steps did not help. see the firebug - output that i have... while viewing the admin-area:

<!DOCTYPE html>
<html class="wp-toolbar" lang="en-US" xmlns="http://www.w3.org/1999/xhtml">
<head>
<body class="wp-admin wp-core-ui js widgets-php auto-fold admin-bar branch-3-9 version-3-9 admin-color-fresh locale-en-us no-svg customize-support">
<script type="text/javascript">
<script type="text/javascript">
<div id="wpwrap">
<a class="screen-reader-shortcut" href="#wpbody-content" tabindex="1">Skip to main content</a>
<div id="adminmenuback"></div>
<div id="adminmenuwrap">
<div id="wpcontent">
<div id="wpadminbar" class="nojq nojs" role="navigation">
<div id="wpbody">
<div id="wpbody-content" tabindex="0" aria-label="Main content">
<div id="screen-meta" class="metabox-prefs">
<div id="screen-meta-links">
<div class="wrap">
<h2>Widgets</h2>
<div class="widget-liquid-left">
<div id="widgets-left">
<div id="available-widgets" class="widgets-holder-wrap">
<div class="sidebar-name">
<div class="widget-holder">
<div class="sidebar-description">
<div id="widget-list">
<div id="widget-1_archives-__i__" class="widget">
<div id="widget-2_calendar-__i__" class="widget">
<div id="widget-3_categories-__i__" class="widget">
<div id="widget-4_nav_menu-__i__" class="widget">
<div class="widget-top">
<div class="widget-title-action">
<div class="widget-title">
<h4>
</div>
</div>
<div class="widget-inside">
<div class="widget-description"> Add a custom menu to your sidebar. </div>
</div>
<div id="widget-5_meta-__i__" class="widget">
<div id="widget-6_pages-__i__" class="widget">
<div id="widget-7_recent-comments-__i__" class="widget">
<div id="widget-8_recent-posts-__i__" class="widget">
<div id="widget-9_rss-__i__" class="widget">
<div id="widget-10_search-__i__" class="widget">
<div id="widget-11_tag_cloud-__i__" class="widget">
<div id="widget-12_text-__i__" class="widget">
<div id="widget-13_widget_twentyfourteen_ephemera-__i__" class="widget">
</div>
<br class="clear">
</div>
<br class="clear">
</div>
<div class="widgets-holder-wrap inactive-sidebar">
</div>
</div>
<div class="widget-liquid-right">
<form method="post" action="">
<br class="clear">
</div>
<div class="widgets-chooser">
<div class="clear"></div>
</div>
<div class="clear"></div>
</div>
<div class="clear"></div>
</div>
<div id="wpfooter">
<div id="wp-auth-check-wrap" class="hidden">
<script type="text/javascript">
<script src="http://literaturen.org/wp-admin/load-scripts.php?c=1&load%5B%5D=hoverIntent,common,admin-bar,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-ui-dr&load%5B%5D=oppable,admin-widgets,svg-painter,heartbeat,wp-auth-check,jquery-ui-position,wp-pointer&ver=3.9" type="text/javascript">
<script type="text/javascript">
<div class="clear"></div>
</div>
<script type="text/javascript">
0

A plugin or your theme is probably calling wp_enqueue_media() and instead of adding a check for admin page and early return they are allowing the scripts to load on every admin page.

You need to deactivate all the plugins and switch to the default theme. If this solves your issue then activate your plugins one by one, checking if the problem re occurs (don't forget to clear your browser cache each time) to identify where the problem is.

  • thx alot - i do as adviced. btw - can firebug help here? – zero Apr 30 '14 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.