0

i'm having problem with displaying admin top bar on my site. I googled and got some solution which i tried like
1) Checking wp_footer in footer.php
2) Checkbox ticked in user profile saying show toolbar will viewing site.

All done but no success. please can anyone point me in right direction. I'm using Classicraft theme.

I'm using wordpress 3.8.3

I have another wordpress installation on same server and can see admin bar their but not on this site. is this theme specific problem ?

Thanks in advance.

1

It certainly can be a theme related 'problem'. To prevent unexpected problems in a theme, I frequently disable the admin bar while working on it. Look in functions.php (or similar) for code that looks like this and remove it:

function my_function_admin_bar() {
    return false;
}

add_filter('show_admin_bar', 'my_function_admin_bar');
  • Thank you very much that helped.:) +1 for your help, giving it here sorry for that since less reputation. – Patty31 Apr 30 '14 at 9:54
  • 1
    add_filter('show_admin_bar', '__return_false'); is enough. WP have a default function to return the boolean. – bueltge Apr 30 '14 at 14:36
  • @bueltge You are right, that is enough. The reason I posted this code, was because of this topic: inkthemes.com/community/threads/where-is-my-admin-bar.7109 – Stephan Vierkant Apr 30 '14 at 14:40
2

On your theme function.php or on similar file look for

show_admin_bar( false ); 

or

add_filter('show_admin_bar', '__return_false');

If you find one then remove it.

1

And I found also that in your Profile (wp-admin/profile.php), you have a checkbox labelled (in french):

Afficher la barre d’outils lorsque vous visitez le site

which means literally:

Show admin bar when visiting the website

(Sorry I don't have an english intall just now so the sentence in English must be a bit different, but you get the idea ;-))

0

I wasted quite a few hours on this and there is another reason that does not seem to be noted anywhere.

You need to make sure that in settings > WordPress Address (URL) and settings > Site address (URL) that if one has www then the other also does and the other way round. Otherwsie it seems while you are browsing the site it is a different domain to the admin area and the admin bar does not show.

0

Check that your theme includes a call to the function wp_footer() at some point, usually at the very bottom of footer.php. That generates the code required for the admin bar to show.

protected by Community Jun 14 '18 at 7:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.