0

I'm not sure if this is because of the new 3.9 update, because I haven't had to mess with any widgets in a while, but my active widgets won't display in the editor anymore.

I've uploaded a screen shot of how it looks here: http://i.imgur.com/Ctbzo3S.png

This may or may not be related, but my Screen Options drop-down does nothing when I click on it and neither does anything else within that widget window.

Here are the errors I'm getting:

  • PHP Fatal error: Call to undefined function select_input()
  • PHP Notice: Trying to get property of non-object PHP Strict Standards: Only variables should be passed by reference
  • PHP Notice: has_cap was called with an argument that is deprecated since version 2.0!
  • PHP Deprecated: Assigning the return value of new by reference is deprecated
  • PHP Notice: get_settings is deprecated since version 2.1!
  • 1
    Sidebars aren't the only thing not showing up. You have a fatal PHP error preventing the loading of the second ~half of the page. Enable debugging and post the output. – s_ha_dum Apr 22 '14 at 20:29
  • Disable plugins one by one to try to isolate the issue, and switch to a bundled theme like Twenty Fourteen. – s_ha_dum Apr 22 '14 at 21:08
  • @s_ha_dum I started at this company after they had outsourced this site build to India, so no one here really knows how or why they did this the way they did. If it were my call, I would redesign it with a better theme and less hardcoded elements (I would use plugins), but I'm not sure that's in the cards right now. I may run that by mgmt soon though, this is just one of many issues that we've had since 3.9. We actually had to revert back from 3.9 to 3.8, so that may have played a part in this as well. Thanks for the input! – Manly Apr 23 '14 at 14:35
  • I am not trying to criticize your build. I just need you to isolate the problem a little. The real killer in that output is this: select_input(). It would help to find that code. The complete error code should tell you where to look. – s_ha_dum Apr 23 '14 at 14:40
  • Oh, I didn't take it in a critical way, don't worry :). I was just giving a bit of background on the situation haha. We've had a few issues lately, so a rebuild may be in order sometime soon. I'm no good at this debugging, that's why I ask people like yourself. I'll take a look at that portion of the log now, thanks. – Manly Apr 23 '14 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.