I recently updated my blog's Wordpress version to 3.9. After running the update I received this message upon trying to access the admin panel.

Database Update Required

WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.

The update process may take a little while, so please be patient.

I am presented then with a button "Update Wordpress Database". When I click the button, after a short pause I am presented with the following message.

Update Complete

Your WordPress database has been successfully updated!

Great. Except that whenever I try to access the admin panel I am re-presented the first message asking me once again to update my database.

Does anybody know of a way out of this infinite loop?

  • What plugins do you have installed?
    – Howdy_McGee
    Commented Apr 18, 2014 at 19:58

2 Answers 2


I had that on one of my sites recently (set to auto update core, so not sure if on 3.9 or one of 3.8.*). Flushing cache fixed it — wp cache flush via wp-cli, I imagine other ways would work just as well.

  • I can double that. Just had a 3.9 install that just needed several runs and a cache flush to work.
    – kaiser
    Commented Apr 19, 2014 at 1:34
  • +1 Flushing the object cache fixes the symptoms of the problem. Commented Apr 19, 2014 at 19:57

This is due to a missmatch between the databases versions you said you are using in the settings.

Please follow this steps:

  1. Go to /wp-include/ folder and open the version.php.
  2. Find the value for $wp_db_version, and write it down.
  3. Now, open your database, check in the table called wp_options
  4. Find the db_version value:

    SELECT option_value FROM yourdatabase.wp_options WHERE option_name = 'db_version';

  5. Those two values must be the same. Change it in the version.php file, not the database.

Source: http://wpquestions.com/question/showChrono/id/4151
Source: https://stackoverflow.com/a/23506630/2615737

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.