1

I've noticed that my process is rather slow and i'd like to speed it up.

I want to be able to duplicate my database from my domain which is blueharlequin.com and work locally thus speeding up the process. The reason I want to do that is because our website has specific loops that I cannot duplicate without knowing the category ID as well as other things.

I've already downloaded wp-db-backup and uploaded the .sql into PHPmyAdmin however everything I click will link me to my website which is not what I want.

My question is how do I make it work locally?

  • 2
    Another, besides what @PieterGoosen in his answer suggested, useful tool is Search and Replace DB by interconnect/it. No affiliation here, I just use it. – Nicolai Apr 13 '14 at 12:07
  • 2
    Both tools recommended are great and I have used them both, but if you do this a lot then take a look at WP_Migrate_Pro. Also, not affiliated in any way, but it has saved me a ton of time. – helgatheviking Apr 13 '14 at 12:14
0

I will suggest Wordpress Duplicator, It is best tool for copying your site to any other host/localhost, and its free, I have used it many times and it works every-time with different server settings.

Please note that I haven't affiliated with it in any way.

| improve this answer | |
3

You will transfer your db a couple of time from and to your live and dev site, so I would suggest downloading and installing a plugin called Velvet Blues Update URL's. This will take care of all the rewriting for you.

This is how to use it. Once installed and activated, go to 'Tools >> Update URL's. This will open the following screen

screenshot 1

In the 'Old URL' field, add the address of your livesite. Don't forget to add the 'www' if your site uses it.

In the 'New URL' add the address of your test local host. It is usually as indicated below if you are using XAMMP.

screenshot 2

You now have to tick all options, and click 'Update URLs NOW'. When your done, just Update your permalinks again.

EDIT

Sometimes you need to change the site and home urls manually in the db in order to get access to your installation. When you log into your db, click on wp_options. Line 1 and 36 is the site and home urls respectively. Change that to your url for your installation

| improve this answer | |
  • For some reason it won't work :/ Once I upload my .sql to PHPmyAdmin all my URL will go to my domain (blueharlequin.com) I had to manually change the 'siteurl' under wp_options and that allowed me to use my local wordpress. Then when I try the plugin i get a "ERROR: Something may have gone wrong. Your URLs have not been updated." I'm sure i'm doing something wrong just not sure what! – Nazar Abubaker Apr 13 '14 at 12:38
  • You should also change the home url in line 36 of wp_options – Pieter Goosen Apr 13 '14 at 13:18
  • I had issues with the home page redirecting to the local version, even after changing wp-options, then i tried this, first without checking the last option and didn't work, then i tried again with "Update ALL GUIDs" and problem solved – Zagen Jan 3 '17 at 4:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.