0

This question already has an answer here:

I want to disable comments on my pages. That means there should be no comment form, no message asking to log in in order to post comments, nothing.

Under Settings > Discussion is the option "Allow people to post comments on new articles." That implies that disabling comments on pages is possible, assuming that "article" means "post or page."

Unfortunately, a comment form still appears despite my unchecking this box. I thought that the option might be overridden on the page itself, but there are no relevant options on the page edit screen.

I really don't want to hack my theme when the facility to disable comments clearly exists already. How can I accomplish this?

marked as duplicate by Chip Bennett, Pat J, fuxia Apr 10 '14 at 23:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This question is better asked at the official WordPress support forums. For a given page, ensure "Discussion" is enabled in "Screen Options", and then you can configure per-page comment settings. – Chip Bennett Apr 10 '14 at 21:59
  • I'm flagging this as a dup because my apparently poor reading skills didn't identify an already-existing answer to this question. Feel free to pile the flags on... – Scott Severance Apr 10 '14 at 22:06

Browse other questions tagged or ask your own question.