1

So, I have no idea what happened, but I tried to migrate a WP site and for some odd reason, it just renders in all Chinese/Japanese.

enter image description here

I've been working on this site locally, and it renders fine without errors.

I've disabled all of my plugins and nothing changes.

I've deactivated the theme and selected another theme, which will work, but then when I select the other theme, it goes back to the asian characters.

So, I'm sure it's with the theme, but I have no idea what's different from my local copy versus the one that I've put up on the dev environment.

I'm just wondering if anyone has ran into this issue before all.

I was using Grunt to compile and compress my SASS files to CSS as well as compress my JS files as well. But I don't know why everything works without issue on my local version versus the one online.

  • This is probably not Chinese, but the browser’s attempt to do something with output it cannot read otherwise. Looks like an encoding problem. Disable gzip. And give us a sample URL. – fuxia Apr 8 '14 at 6:24
  • @toscho: Here's the URL: dev.boostmktg.com/er2 – ultraloveninja Apr 8 '14 at 11:36
  • Gzip is still enabled. Turn it off to get that factor out. – fuxia Apr 8 '14 at 11:44
  • Ok, I think I got it turned off. I added SetEnv no-gzip dont-vary to a .htaccess file. Not too sure if that's correct or not. – ultraloveninja Apr 8 '14 at 14:02
0

Ok, I fixed the issue.

I noticed that if I went to any of the other pages, the theme showed up fine, but if I went to the home page, it was rendering the Asian characters.

I noticed that in my home page template file there were two NUL charactares that had apparently slipped into the file:

enter image description here

I do not know how they got there, but once I deleted them, everything was back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.