0

In my self-hosted WordPress site, if I create a post with "/etc/" (without quotes) in it anywhere, I get a 404 Not Found when I save the post.

Wrap it in <pre> tags, or even escaping the characters (&#47;&#101;&#116;&#99;&#47;) doesn't work.

I've tried disabling all my plugins, but that doesn't make a difference.

Any pointers will be greatly appreciated.

  • etc is a linux system directory; that's one reason why the slug is not allowed at that host. – markratledge Apr 5 '14 at 14:19
  • yeah I realised that - however, I was writing a blog post about some shell scripts, so /etc/blahblah was included – Ace Apr 5 '14 at 16:24
1

Ther is probably mod_security or a similar add-on installed on your web server. Find it, take the word etc out of the list of stop words.

WordPress doesn’t do that.

  • Sounds reasonable, thanks. This site is on shared hosting, so I tried to try switching off mod_security rules in .htaccess using this answer but that didn't help. Though there is a comment on that answer saying that mod_security could have been compiled to prevent .htaccess overrides. Do you suppose there's anything else I could try? – Ace Apr 5 '14 at 13:55
  • @Ace Ask your web hosting support. – fuxia Apr 5 '14 at 13:57
  • They're called No Support Linux Hosting :-), but thanks again for pointing me in the right direction! – Ace Apr 5 '14 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.