Custom menu has stopped working since upgrading to 3.8.1. When trying to add items from the left they do not show up as movable items as they should do under Menu 1, however the text changes to: "Drag each item into the order you prefer. Click the arrow on the right of the item to reveal additional configuration options.". Clicking Save then takes me back to Screenshot 1 i.e. nothing is saved (See Screenshots 1 & 2)

Before adding item

After adding item

Things tried:

  • Disabled all plugins
  • Reinstalled WP from wp-admin/update-core.php
  • Changed to default theme
  • Repaired tables in PhpMyAdmin
  • Deleting this menu and created a new one

Solution: I'm not sure what was wrong with it but I previously upgraded from quite an old version? I did a fresh install of Wordpress and imported posts, pages, plugins etc. Working now, maybe the old structure screwed it?

2 Answers 2


I've had this happen to me in the past at least 3-4 times but I don't really know what caused it. More often than not I was able to solve it by deleting the menu I was having problems with and creating a new one.

  • Thanks for your suggestion. Ive tried this. Ill edit my post
    – ptimson
    Apr 2, 2014 at 23:49

You need to save the menu name first when you create it. After which you can add menu items to the menu.

There may be issues with a conflict on the name of the menu. The database updates with WordPress 3.8.1 may have not update. Try re-updating Wordpress, if that doesn't work, and it isn't an issue with plugins then go to the next paragraph.

Also for me the issue always comes down to File Permission errors. See here http://codex.wordpress.org/Changing_File_Permissions The File Permissions may be causing issues. Make sure the CHMODs are correct and the CHOWNs are correct (I generally make the CHOWN the same as the one that runs apache (or nginx, etc). CHMOD is file read/write/execute permissions and CHOWN is who owns the file.

  • 2
    Please edit this to provide a more thorough answer.
    – s_ha_dum
    Apr 2, 2014 at 22:58
  • Saving the menu does not help. There were no pre-existing menus so there cannot be conflicts
    – ptimson
    Apr 2, 2014 at 23:08
  • Which part of database are you referring to?
    – TomC
    Apr 3, 2014 at 7:51
  • I have updated it with more information. It probably isn't a database issue if he has updated again. But it could be file permissions.
    – Vagish
    Apr 3, 2014 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.