0

I just installed Gravity Forms 1.8 and made a form with a multi-upload field.

The field shows up alright, but the field just, doesn't works. Clicking the Select Files does nothing, and dragging files in the zone only opens the file in my browser.

There is no errors in the console of Chrome and Firefox

What could prevent the field from working?

  • Do uploads generally work? – kraftner Apr 1 '14 at 15:10
  • Uploads in /wp-admin/media-new.php work as intended. – Fredy31 Apr 1 '14 at 17:36
  • You should contact Gravity Forms support – Tom J Nowell Sep 4 '14 at 11:33
2

The most common cause of the multi-file upload field failing to function is the scripts being included down in the footer when they should be up in the header. This usually happens when using the function call to embed the form, there is a second function call you also need to use to ensure the scripts are included correctly: http://www.gravityhelp.com/documentation/page/Embedding_A_Form#Enqueue_Scripts_and_Styles

Gravity Forms 1.5 introduced the gravity_form_enqueue_scripts() function which allows you to easily enqueue the necessary Gravity Forms' scripts and styles when manually embedding a form. This is also useful if you are using a GF widget and do not wish for the styles and scripts to be loaded inline. https://www.gravityhelp.com/documentation/article/gravity_form_enqueue_scripts/

  • could you please include that script here please. That link is very general and doesn't expose that function you mention very well! thanks props.. – elliotrock Mar 27 '17 at 22:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.