I've seen many other related questions, but all of them are resolved with just adding the name format at the top of the plugin main PHP file, and/or manually downloading and extracting the plugin, but none of those answers worked for me.

I'm talking about the Wordpress Users Plugin. After downloading and extracting it in wp-content/plugins/ directory, I can't find it in the dashboard list.

I've checked that the main file (wp-users.php) is placed at the main path, and it starts with the plugin name:

Plugin Name: WordPress Users
Plugin URI: http://kempwire.com/wordpress-users-plugin

I'm confused about what can be happening. Any idea?

  • Do you have debugging information?
    – s_ha_dum
    Commented Mar 30, 2014 at 18:12
  • @s_ha_dum - No. Debugging is enabled (define('WP_DEBUG', true);), but no errors are shown.
    – Manolo
    Commented Mar 30, 2014 at 18:21

2 Answers 2


If the plugin headers are correct, then the only option that comes to my mind is that the owner and permissions of the plugin file or its directory (if it is in one) are incorrect and WordPress cannot read the plugin file. Other than simply being logically important, if you check the source you can see that the Core specifically checks whether the plugin files are readable.

See the following for the appropriate settings: http://codex.wordpress.org/Changing_File_Permissions
http://codex.wordpress.org/Hardening_WordPress https://wordpress.stackexchange.com/a/96454/21376


Check the permissions on the files within the plugin directory, starting with the main php file. At a minimum the permissions should be 0644 for Wordpress to read the file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.