1

I've followed most Wordpress migration guides that I can find. The steps I've taken sum up to the following:

  1. Export my wp database from the existing production site
  2. Spin up a new Ubuntu Server with LAMP stack, PHPMyAdmin, and ssh
  3. Copy my entire wordpress site from root (htdocs) directory to the /var/www/ directory of my new server
  4. Create a new database on the new server's mysql, import the export from step 1
  5. Change the wp-options for site_url and home (I changed them to http://)
  6. Run the script found here to clean up the rest of the db.

When I point my browser to the ip address address of the new server on my local intranet I get the error:

Not Found

The requested URL /login/ was not found on this server.

Apache/2.2.22 (Ubuntu) Server at 192.168.0.176 Port 80

I get the same error when I try to go to /wp-admin. I think I may not be pointing the url correctly but I'm not sure where to point it to if it's not the root directory of my new server.

My .htaccess files are located at

/var/www/.htaccess
/var/www/wp-content/uploads/.htaccess
/var/www/wp-content/themes/Portal/library/.htaccess
/var/www/wp-content/plugins/s2member-files/.htaccess
/var/www/wp-content/plugins/s2member-logs/.htaccess
/var/www/wp-content/plugins/akismet/.htaccess
/var/www/wp-content/plugins/s2member-pro/includes/.htaccess
/var/www/wp-content/plugins/s2member/includes/jquery/.htaccess
/var/www/wp-content/plugins/s2member/includes/.htaccess

The content of the root .htaccess file is

# BEGIN WordPress
Options FollowSymLinks
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_URI} ^/Appledoc.* [OR]
RewriteCond %{REQUEST_URI} ^/Javadoc.*
RewriteCond %{HTTP_COOKIE} !^.*wordpress_logged_in.*$ [NC]
RewriteRule . /wp-login.php?redirect_to=%{REQUEST_URI} [L]
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

# BEGIN s2Member GZIP exclusions
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{QUERY_STRING} (^|\?|&)s2member_file_download\=.+ [OR]
RewriteCond %{QUERY_STRING} (^|\?|&)no-gzip\=1
RewriteRule .* - [E=no-gzip:1]
</IfModule>
# END s2Member GZIP exclusions
6
  • Does the server itself work? That is, is a basic uncomplicated HTML file accessible? – s_ha_dum Mar 27 '14 at 21:42
  • Yes, I can create an index.html file with some text in it and access it from another computer's browser – JuJoDi Mar 27 '14 at 22:01
  • What is in your .htaccess? – s_ha_dum Mar 27 '14 at 22:04
  • Moving a .htaccess file can under some circumstances cause problems, and that is not a Core RewriteRule unless maybe it is a Multisite rule. If these seven files are not at your site root, where are they? And please edit the additional information into the question. – s_ha_dum Mar 28 '14 at 13:33
  • There is a lot of non-Core stuff happening there. I would rename at least this one file-- /var/www/.htaccess-- temporarily and see if you can't get more normal behavior. – s_ha_dum Mar 28 '14 at 14:36
1

I know this is ancient history, but this one definitely needs an answer as it is the first hit when searching for this problem on Google.

You may have forgotten to enable the rewrite module for Apache:

Enable the module in Apache:

a2enmod rewrite

Followed by Apache restart - systemd method shown below as this is currently what you are most likely to find on CentOS servers:

systemctl restart apache2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.