0

For some reason WordPress started to add rel="nofollow" and target="_blank" to some of my links in my posts and pages. Not to all my links but randomly.

I really dont know why because when I'm editing my post it is just a normal link without rel="nofollow" and target="_blank". Adding target="_self" or rel="dofollow" doesnt change anything.

Why is this hapening and how can I solve this problem? Anyone got the same problem and knows a solution?

Thanks in advance:)

This is an example page and I'm taling about the link "control panels"

1
  • 3
    Try disabling all your plugins, if that solves your problem, enable them 1 by 1 to find out which one is causing the problem. Then exterminate it!
    – Howdy_McGee
    Commented Mar 24, 2014 at 21:57

2 Answers 2

0

When you place a link into a WordPress post or page the link window, where you specify where the link is to lead, has a check box for specifying that you want to open the link in a new window.

There is a similar box in the advanced settings tab of any graphical element you place in a post or page.

If one of those boxes is not checked on the "target= _blank" links then I would suspect a setting in one of your plugins, probably an SEO plugin.

The troubling part is the inconsistency. A plugin setting should be a consistent result.

0

An old post, but still a relevant issue,

@SierraTR is correct (in my case), it's an SEO plugin (RankMath).

But I'm wrong, not the plugin (and it corrected me). The default RankMath setting is to open all external links in a new window:

'WP Dashboard' > 'Rank Math SEO' > 'General Settings' > Links (tab) > 'Open External Links in New Tab/Window' is toggled on.

What I should be doing is linking to internal pages via relative paths.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.