1

I recently had my WordPress blog's domain reassigned as the primary domain on my BlueHost account. The blog is in a sub-folder of public_html/. Below is the contents of the .htaccess file I re-uploaded to replace the default .htaccess file. When I tried navigating to my dashboard by clicking on the Dashboard link from the site, I am greeted with a directory listing for wp-admin. However, when I use ofthreadsandthings.net/wp-admin/index.php, things are fine.

The .htaccess (root level)

# Use PHP54 Single php.ini as default
AddHandler application/x-httpd-php54s .php

AddType audio/mp4 .m4a

# BEGIN WordPress
RewriteEngine On
RewriteCond %{HTTP_HOST} ^(www.)?ofthreadsandthings.net$ [NC]
RewriteCond %{REQUEST_URI} !^/ofthreadsandthings/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /ofthreadsandthings/$1
RewriteCond %{HTTP_HOST} ^(www.)?ofthreadsandthings.net$ [NC]
RewriteRule ^(/)?$ ofthreadsandthings/index.php [L]

# END WordPress

1 Answer 1

0

Adding this directive at the beginning of the .htaccess file should do the trick:

DirectoryIndex index.php

If this doesn't do the trick, try creating an .htaccess file in the wp-admin folder and place this directive in there (depending on what HTTP server your system runs on and a variety of other settings, modifying just the .htaccess in the root domain might not inherit the directives to subfolders).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.