0

I've been searching for a couple of hours for a solution, but so far haven't found anything. I updated my site's permalink settings from 'post name' to 'day and name' and everything seems to be working fine except that the two most recent posts redirect back to the homepage and add the year to the url.

I've tried resetting the permalinks to default and changing back to 'day and name', but this doesn't seem to work. If I insert index.php in front the custom permalink structure, the links will work, but I don't want index.php to display in my URL.

I can't seem to figure out why this would be an issue for only two posts out of hundreds. The only difference between these two posts and the others is that they are the two most recent.

Any help would be much appreciated, as I've been searching for a while and can't seem to find a solution. Thanks!

  • You might want to try deleting the .htaccess file from the root of your site. – Roee Yossef Mar 18 '14 at 0:33
  • The old URLs redirect to the wrong page, or the new URL format redirects to the wrong page? What are the post names of the two most recent? If they match another rewrite pattern (like year, month, day) WordPress may unexpectedly redirect those requests. – Milo Mar 18 '14 at 0:53
  • Thanks for the replies guys. Just the two posts were redirecting to the homepage, and the URL was appended with '/2014' but I just checked the site again and now they're working fine, even though I haven't changed anything. No idea what the issue was, I spent several hours trying to figure this out, and still don't know what the problem was. Oh well, at least it's working now. Thanks again. – Sean Henderson Mar 18 '14 at 4:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.