7

I've been developing for Wordpress for a few years now without any trouble on an old XP/WAMP development server (v1.7.4) but recently have been getting the error "Connection lost. Saving has been disabled until you’re reconnected" whenever I try to update either Wordpress Posts or Pages. The majority of what I've turned up on the subject points to plugins as the source of the problem, Sadly, I find that even in a clean install of wordpress 3.8.1, in a new DB, without any plugins the problem persists. Next logical culprit then is the server. I check the logs, and find nothing. In the process of migrating my workflow to a newer Windows 7 platform (WAMP v2.2.22) I created a new install there, and the problem is gone. I've run the php.ini's from both servers through a difference engine hoping to suss out the cause, but I'm afraid it's a bit beyond me where the issue might be, nor how to share the results of the comparison here, either as a flat file, or CSV. Any thoughts?

3
  • I have the same problem, it's only just started to happen on 3.8.1 and have gone through the same processes as you. There doesn't seem to be any fixes for it!
    – Rob
    Mar 26, 2014 at 10:48
  • Yes, I am facing the same trouble and the WP version is 3.8.1. Apr 3, 2014 at 7:05
  • Maybe read this, I had similar issue and finally resolved them, hope it helps wordpress.org/support/topic/…
    – user76310
    Jul 16, 2015 at 23:10

3 Answers 3

3

That message is a result of your server throwing a 503 error and the WordPress Heartbeat API catching that error. See https://core.trac.wordpress.org/ticket/25660 for the background on the fix that WordPress introduced to save offline edits.

Things to check on your computer are if WAMP is actually running when you're getting this message (check the status icon in the system tray). You should also check to make sure no other programs are trying to take over the port WAMP uses. Reports of Skype and TeamViewer taking control of ports 80 & 443 abound, as well as fixes for each of them.

If you haven't checked out the WAMP forums, here's a page that outlines the debugging steps for the 503 server error, and fixes for Skype and TeamViewer: http://forum.wampserver.com/read.php?2,115474,115576.

1
  • 1
    @moganestes Thanks for playing, but sadly... no... none of the above. My error logs are clean, nothing running on this machine but WAMP, FF, Chrome, AVAST, and Notepad++. I do however think the first link you provided is telling. I have hated WP's forays into Auto-Draft et.al. from the beginning, and it appears -- reading between the lines int the link provided -- that the Heartbeat API remains suspect, and not yet ready for prime time. I'm betting the answer lies there somewhere.
    – user48973
    Apr 29, 2014 at 13:54
0

Try the following:

  1. Disabled all plugins, removed plugins folder entirely - problem still persists.
  2. Removed the .htaccess file - problem still persists.
  3. Tried a fresh install - problem still persists.
  4. Cleared browser cache.
  5. Checked the server for any auto updates - there haven't been any.
  6. Changed the autosave to various times define( 'AUTOSAVE_INTERVAL', 160 );

More info

-1

So here you go I downloaded and installed manually onto my admin plugins page on both of my domains and the problem seems to have stopped. I first stumpled upon the php compatibility checker which had a few of its own issues and having to enable the WP-cron plugin which i had to download and install as well or the checker would stall out. https://wordpress.org/plugins/php-compatibility-checker/ https://wordpress.org/plugins/wp-crontrol/ And even after all this i was still having the issue at hand i came across plugin detective plugin. https://wordpress.org/plugins/plugin-detective/ after running all 3 plugins on both of my pages everything seems to have been fixed or the problem removed at least. I hope this helps you

Not the answer you're looking for? Browse other questions tagged or ask your own question.