-1

I have developed a theme and had to export all contents via the exporter. Now when i import them via the importer plugin the posts etc get imported but there is an error importing media. Could you please help me out?

Here is a screenshot:

  • Can your server connect to the server on which the media is on? – Mark Kaplun Feb 28 '14 at 15:01
  • You should call the plugin author. – Pieter Goosen Feb 28 '14 at 15:01
1

Admittedly, this is a guess.

  1. The exporter, in the versions I have used, does not save your files to a local disk. It creates an XML file with references to your images on a server somewhere.
  2. When the importer reads the XML file, it will download from that server and upload to your new installation.

If your images are not available-- not accessible for download-- the importer cannot access the server where the images are stored, you will get upload failures. I am guessing that that is what is happening. Perhaps, the old server is refusing connections, or DNS is preventing access, or the old site has been taken down.

If it is a DNS problem, you should be able to solve it by editing the XML file to replace the domain name with the numeric server IP. Untested, but can't think of why that wouldn't work.

If the site has been taken down, I hope you have backups of the images somewhere.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.