Uploaded an image via standard 'add new' dialog to the WordPress Media library. Here were the original Media Settings:

  • Thumbnail - 150x150
  • Medium - 300x300
  • Large - 1024x1024

I uploaded a 650x144 image.

Resulting generated image sizes:

  • 150x144.jpg
  • 300x66.jpg
  • 336x144.jpg

Only the medium image has the correct ratio. The other two images are basically a crop of the middle of the original image.

I've tried deselecting the 'crop thumbnail' box next to the thumbnail. I've tried changing the height to 0. So far nothing has worked. What am I missing?

  • Are you using your own theme? If not, check the functions.php file to see if other sizes were set. Also, you can turn crop on off via a function.
    – gdaniel
    Commented Feb 28, 2014 at 1:38
  • What you should do is crop the image before uploading if you want the best quality. Commented Feb 28, 2014 at 2:44
  • @gdaniel - yep, two additional sizes, both specifying height which throws off the aspect ratio unless you pre-size to match. Thanks!
    – dixonge
    Commented Feb 28, 2014 at 12:37

1 Answer 1


Under settings >> media, change the height attributes to 9999, and untick Crop thumbnail to exact dimensions (normally thumbnails are proportional) under the thumbnail size if it is ticked.

When you are done, download and install "Force Regenerate Thumbnails". This is actually better than "Regenerate Thumbnails" as it deletes all redundant image sizes.

  • Thanks for the tip. In this case I don't want to screw up any existing custom images the client may have, but noted for future use :)
    – dixonge
    Commented Feb 28, 2014 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.