I recently updated my site to 3.1 and now the frontend of the site will not load. The weird thing is the admin section does load and is some what functional (sometimes the pages go blank and I have to reload, and sometimes reloads don't work). I had to install and activate a maintenance plugin while I try to trouble shoot the issue.

I tried to recall anything that I mightve done to cause this and can't see what caused this. I notice that if I visit my domain, with my maintenance plugin activated, it will show the maintenance message, but if the maintenance plugin is not activate this site loads a blank page.

In in the general settings, I changed the "wordpress address" to see if that would somehow load the site by putting the direct url location of the site, but that didn't work. With the actual domain in both fields (wordpress address and site address), the admin works but the frontend doesn't load except in maintenance mode.

I would appreciate some advice with this. I just went in to do a little maintenance and I spending 4-5 hours on this problem.

The link to my site is here

Is this a common problem on updates? I hope this is fixable, if not is it possible to downgrade wp to the previous version (if its necessary)?

Thanks in advance for any help with this.

  • 2
    In wp-config.php turn on debug mode. This turns off error suppression so you can see what's wrong. define('WP_DEBUG', true);
    – Andy
    Mar 30, 2011 at 23:54
  • This helped me locate the coding error. It was a line I needed to comment out. But besides that the site is still acting buggy. I'll find the root problem. Thanks!
    – user1893
    Mar 31, 2011 at 13:03
  • @user1893 Can you update us on this? If you found the solution could you add it as an answer then accept it as the correct answer. Thanks!
    – Chris_O
    Apr 30, 2011 at 7:59

2 Answers 2


I've had this same issue a couple of times now. Generally I've resolved it by manually downloading 3.1 and replacing the files in the directory. After the transfer is complete I was able to log in and update my database with the drop-down it presented.

  • This was definitely a database credentials issue. I triple-checked the details and it worked. Thanks a lot for your advice. Sorry for the late response.
    – user1893
    May 27, 2011 at 14:25

Very typical things to do: Rename your plugins folder to old_plugins to deactivate all plugins. Switch to Twenty Ten and see if it works, too. Then reactivate plugins one by one until it white screens again.

  • I tried this, but this didn't fix the problem. I think I might have to downgrade or something... Thanks for the advice.
    – user1893
    Mar 31, 2011 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.