1

Presently running Wordpress 3.8.1 French but Wordpress is asking me to update to a new version.

When doing the update, I get the following error:

 Warning: copy(/home/XXXXXX/domains/XXXXXX.com/public_html/wp-admin/includes/update-core.php) 
 [function.copy]: failed to open stream: Permission denied in
 /home/XXXXXX/domains/XXXXXX.com/public_html/wp-admin/includes/class-wp-filesystem-direct.php
 on line 217

La mise à jour ne peut pas être installée parce que nous n’allons pas pouvoir copier certains fichiers. Ce problème est généralement dû à des incohérences dans les permissions de fichiers.: wp-admin/includes/update-core.php

Échec de l’installation

Translation for above:

The update cannot be performed because we will not be able to copy certain files. This problem is usually associated with inconsistencies in the files permission: wp-admin/includes/update-core.php

Installation failed.

We need to know what type of files inconsistencies this is related to and what would be the procedure the fix it.

1

The user your server is running as needs to be able to write and modify the files in WordPress core. Namely that the updater was told: Permission denied when it tried to change wp-admin/includes/update-core.php.

What the permissions will need to be for this to work are different from server to server. This article talks more about file permissions and the relevant folders, and may be helpful, but there is no definitive "set it to 123 and it will work" answer.

My personal recommendation would be to never use the auto-updater, and update using:

  • Git
  • SVN
  • Secure FTP

Simply placing the new version of WordPress over the top of your old version should do the job. It will ask to update your database on the next visit to the admin interface. This will not make the built in auto-updater work in the future however, but it will upgrade your copy manually.

  • Will do. Appreciate the help. – ducktape Feb 17 '14 at 14:50
0

You need to be sure that PHP and therefore WordPress is able to edit your files. Have a look at http://codex.wordpress.org/Changing_File_Permissions to see how to change file permissions.

  • Could you tell me what files should I changes the permissions ? – ducktape Feb 17 '14 at 14:46
0

I had this same problem and I only found one article that fixed my issue. It depends on who is doing your hosting, and what type of Hosting it is. One way you can do it is through your ftp program. I use filezilla.

  1. open Filezilla (ftp program I use) connect to your hosting account just like you do when tranferRing files.

  2. Go to your root domain/or where ever your directory has wordpress (mine is a subdomain /blog)

  3. click on the folder and right click. When you do so (on Filezilla anyways) you will see a link for "file attributes." Click it.

  4. That will give you all various permission options. Don't worry about all the check boxes, just move down to "numeric value." I just set that at 755, then click a box on there that says "recurse into subdirectories" and then "apply to directories only" and hit ok. That changes the folders/directories to 755.

  5. then you can go in and change files also, and I would use 644.

If you go through these steps and you get a message in your ftp saying "command not understood" It probably means your hosting is a windows server, not a linux, and you will have to go through another process. This happened to me. I don't know how other hosts do things but I can run you through it on godaddy windows hosting.

GoDaddy Windows Hosting

  1. login to godaddy, and go to "webhosting" "Launch" FTP manager.

  2. click on the check box on the left of the Folder/Directory where wordpress resides (again, my own wordpress is on a subdomain: blog.mysite.com. So I check the box next to the "blog" folder.

  3. There should be a menu on top, one of them being "permissions."

  4. click on it and uncheck the box "inherit" and check the other 3 ("read, write, reset children to inheret).

  5. keep your file manager panel on GoDaddy open. In another window open your wordpress admin page and the update should go through.

6.If that works you can (optional, but puts back up some security) go back to your file manager and reset the folder that you just changed and check all boxes except for "write."

Thats how I got it to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.