1

I'm setting the specific "from" address using wp_mail_from.

I've verified that it's actually called and I'm passing a legit me@domain.com email address.

But by the time it hits /var/log/mail.log, the from address is "localaccount@my.hosting.server.com".

In the wp_mail( ) call I'm even setting the headers 'From:....'. Doesn't matter, it's still ignored.

I'm not sure this is a wp thing, but I've checked all my php settings and I'm not finding anything that would indicate that it forces the "from" of every email.

For now I've used a generic map in postfix to convert the local account email address to a legit "from" address. But the problem is I need some emails in wordpress to be sent from one address and other emails sent from another.

I have it setup in wp_mail_from to set the correct from address, only it's ignored completely somewhere along the way, just not sure what's doing me in.

Ideas?

  • you may have ssl server kindly try to add existing mail in from option – Vikas Gautam Feb 17 '14 at 5:38
  • Try sending the email through a remote server such as Gmail to see if the same results occur. It could be the mail app is changing the From header. wpbeginner.com/plugins/… – Seamus Leahy Feb 17 '14 at 5:50
  • from mail is that the existing mail in your account or any server kindly check if that not exists it will not work on ssl server – Vikas Gautam Feb 17 '14 at 5:54
  • presently you are passing the defout name@yourdomeain.com that is not already exists mail – Vikas Gautam Feb 17 '14 at 6:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.