0

I have two custom post types setup like this:

add_action( 'init', 'create_post_type_News' );
function create_post_type_News() {
    register_post_type( 'news',
        array(
            'labels' => array(
                'name' => __( 'News' ),
                'singular_name' => __( 'News' )
            ),
        'public' => true,
        'has_archive' => true,
        'supports' => array(
            'title', 
            'editor', 
            'author', 
            'thumbnail'
        )
        )
    );
}

when I try to view the page (/%postname%/ is used as permalink) I get the standard 404 message "Not Found Apologies, but the page you requested could not be found. Perhaps searching will help."

I've tried the standard fix:

  • set permalink back to default and save
  • set permalink back to desired style and save

The page will show with permalinks as default but not customized.

7
  • 1
    I have checked your code (Copied and reset permalink) and have found no problem with it. It's creating posts called news and displaying full posts. URL where to search this post is: SITENAME/news/POST_SLUG Commented Feb 14, 2014 at 7:15
  • I've actually just followed this step by step and still have the issue: How to Fix WordPress Custom Post Type Permalink 404 Error
    – dcp3450
    Commented Feb 14, 2014 at 7:27
  • Enable the rewrite module on your server.
    – fuxia
    Commented Feb 14, 2014 at 7:28
  • according to hostgator to have rewrite on I just need a .htaccess file and turn it on through there. I've done this already. The permalinks work for everything but my custom post types (I have two)
    – dcp3450
    Commented Feb 14, 2014 at 7:35
  • Have you tried Silent Flush?
    – fuxia
    Commented Feb 14, 2014 at 7:41

0