0

I am unable to see it network admin link in a multisite blog. Can anyone tell me how to activate it again? I am logged in as super user. For the main blog I could see, I used to see the network admin link previously for any other blogs too if am logged in as super user but now I am unable to see. check the below images,

Before, I can see network for all sites if am logged in as super user

enter image description here

Now, I cannot see network admin link for any blogs

enter image description here

  • What has changed - any plugin updates, WP Core updates, etc. ? – Eric Holmes Feb 13 '14 at 19:40
  • I tried to network activate a plugin, but after this I deactivated and even tried deleting it. Still cant access. – NEO Feb 13 '14 at 19:43
  • When I try to access the url like 'blogurl/wp-admin/network' I get "Error establishing a database connection" though I could access 'blogurl/wp-admin' – NEO Feb 13 '14 at 19:50
  • It sounds like the plugin tried to alter something in the database, and failed. Make sure your wp-config.php multisite settings are still in tact, and so is your .htaccess file. – Eric Holmes Feb 14 '14 at 16:19
  • Or that it removed you as a super administrator. – Eric Holmes Feb 14 '14 at 16:19
0

The problem was that the username of the super admin was changed and this did not reflect in other blogs of the system. The below query solved my problem,

update wp_sitemeta set `meta_value` = 'a:1:{i:0;s:6:"adminusername";}' where `meta_key` = 'site_admins'

and

update wp_sitemeta set `meta_value` = 'adminmail@adasd.com' where `meta_key` = 'admin_email'
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.