1

I have created a WordPress site using Azure so when the site went live the url was http://apidublin.azurewebsites.net/.

I changed this to http://www.apidublin.com/ using my domain hosting site and changing the settings on Azure.

However when I click on a post it changes back to apidublin.azurewebsites.net and stays like that. I know that in the general settings I shouldn't touch the wordpress url as I'm not looking to migrate the site but can I change the site url so I don't have this problem anymore?

2 Answers 2

1

Download and install "Velvet Blues Update URLs". Add your old url in the "Old URL" field, the new one in the "New URL" field, check all the checkboxes and click "Update URLs". Update your permalinks afterwards

1
  • Strange, 0 urls are updated but old url is still showing up in the settings etc.. Any tips?
    – Rafael
    Nov 30, 2018 at 9:47
3

You need to update the new URL in the WordPress Address (URL) and Site Address (URL) in General settings. Some of your media may be pointing your old site or may not be available in that case you need to install a plugin named Search and Replace and you need to replace the every occurrence of the old URL with the new one.

3
  • 2
    Just be careful with search/replace - if you saved serialized data, it may break your site.
    – fischi
    Jan 22, 2014 at 10:31
  • Do I use this plugin before I change the urls? I changed the Wordpress Address URL before and I wasn't able to log in afterwards.
    – Ronan
    Jan 22, 2014 at 10:32
  • @fischi (interconnectit.com/products/…) is a great solution when dealing with serialized values
    – Raja67
    Jun 23, 2014 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.