0

I'm in the process of forcing a few pages with forms to use SSL. After setting up the SSL, I opened up the console and begin debugging the errors. I ended up installing WordPress HTTPS plugin and force SSL in each specific pages. It did help fix a few errors except one.

[blocked] The page at 'https://www.yourdomain.com/something/' was loaded over HTTPS, 
but ran insecure content from 'http://www.yourdomain.com/?mcsf_action=main_css&ver=3.8':         
this content should also be loaded over HTTPS.

I'm bummed out after a few hours and research trying to get rid of the last error. The Style Sheet is from the Mail Chimp plugin.

I'm also generating another error when I try to submit the Mail Chimp form:

XMLHttpRequest cannot load http://www.yourdomain.com/. 
No 'Access-Control-Allow-Origin' header is present on the requested resource. 
Origin 'https://www.yourdomain.com' is therefore not allowed access. 

Besides these errors, in the general settings, the WordPress/Site URL is set to http://www.yourdomain.com (dummy url).

If anyone could please help me, It would be greatly appreciated.

  • Have you tried setting the Wordpress and site URL to https:// instead of http://? – Jay Neely Jan 22 '14 at 2:47
  • For this project, I only want SSL on pages with forms so I would prefer not to change the whole site to use https. For the 2nd issue, I found out that MAIL CHIMP plugin doesn't use SSL for forms so I'm going to have to use MAIL CHIMP's API but I still can't figure out how to fix the first error. I did some more research and came across a solution which would require you to go into the mailchimp file and comment out the CSS dynamic call. – rolu Jan 22 '14 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.