1

I recently started learning wordpress. Out to curiosity of changing settings, I changed permalinks to Month and Name. After that all my posts and pages have stopped working and show me a 404 Error. I am not being able to figure out why is it happening.
I even tried posting new posts and even they doesnt work.
Please suggest any solution. I am using WP 3.7 on windows machine with wamp.

4
  • It should be not getting an error. Have you try to change your theme and deactivated the plugin (in case you activated it)?
    – ucon89
    Jan 16 '14 at 13:01
  • Theme is default twenty thirteen. I tried changing it to twenty fourteen. But didnt help. There's no active plugin. Its a new fresh wp installation. Thing is when I change permalink to default it starts working. Jan 16 '14 at 13:08
  • @ucon89 there is probably no problem with the theme or plugin, but some .htaccess files doesn't allow you changing permalinks, and that gives indeed an error 404
    – Maartje
    Jan 16 '14 at 13:28
  • can we see your htaccess file?
    – Tom J Nowell
    Jan 16 '14 at 13:46
2

In wamp you have to manually click/unclick an option to change the .htaccess(and allow permalinks with that).

To do this , click the wamp icon on your (windows) task bar, choose apache > apache modules and check 'rewrite module'

1
  • 1
    Thank u so much.... That worked for me.... Will give you a plus once I have enough reputation.. Jan 17 '14 at 4:41
0

This is a problem with your .htaccess file. Try going into the permalink settings and saving them again just to be sure. If it warns you that the .htaccess file has not been updated, you will need to either change the permissions, or update it manually.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.