0

I have import on my local webserver a backup of a website made using WordPress but I am finding some difficulties with PermaLink configuration

The main problem is that if I use the permalink setted as Article Name I can see the homepage but if I click on the articles links into the homepage (to see the article) I always obtain the following message error:

Not Found

The requested URL /wordpress35/2012/10/11/se-milano-avesse-il-mare-anzi-no-la-montagna-di-campiglio/ was not found on this server.

If I instead I use the Default settings for permalink (http://localhost/wordpress35/?p=123) I have no problem and I can access to the articles in my website

I think that this is a .htaccess problem. Can you help me to create an .htaccess file that solve this problem?

This is my actual .htaccess file content:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

I need to use the URL format described as: http://localhost/wordpress35/my-article-name

  • See the Codex page on .htaccess for the default WordPress .htaccess rules. – Pat J Jan 13 '14 at 19:20
  • mmm I have put a .htaccess file taking the code fromt the codex page but still no work, I have insert the code in the origina edited post – AndreaNobili Jan 13 '14 at 19:23
  • does your server have mod_rewrite enabled? – Milo Jan 13 '14 at 19:25
  • yes, infact: andrea@andrea-virtual-machine:~$ sudo a2enmod rewriteModule rewrite already enabled – AndreaNobili Jan 13 '14 at 19:31
  • is your .htaccess file being parsed by the server? you're getting your server's 404 document, when you should be getting a WordPress 404 if the permalink structure is incorrect, which seems to indicate that your .htaccess file is being ignored entirely. – Milo Jan 13 '14 at 19:33
2

You may also want to look into who the owner is of the folders as well as permissions. I've just recently completed setting up multiple WP sites on a local Ubuntu server & the majority of issues I ran into were permissions related.

WordPress documentation for permissions: http://codex.wordpress.org/Changing_File_Permissions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.