0

I am using wordpresss cms. I am trying to get things right with Google's rich snippets tool. Though, I have able to set updated, author and 'entry-title' correctly I am still having trouble setting my title in a correct way. In the rich snippets testing tool I am having this Error: Missing required field “entry-title”. I tried a solution that was suggested here but it did not work. Below is the code that I tried.

<h1 class="entry-title"><? php the_title();?></h1>

FYI, I also use wordpress seo plugin by yoast. I thought about asking this at webmasters-stackexchange but thought I will ask here first as it might be related to wordpress. The other reason I need to get this sorted is, coz I am getting errors in my search results as displayed within google webmasters tools. enter image description here


enter image description here

0

Look at your page source and see if your html markup actually contains the entry-title class, i.e.:

<h1 class="entry-title">My Page Title</h1>

as it must for the span and other classes for date and author.

If it does, clear your cache and try Google's testing tool again. If your page source does not contain the correct markup, be sure you have edited the correct page template. Themes can contain several different templates for pages.

Dev Tools are great for this sort of thing; use Firebug with Firefox, or use the developer tools in Chrome or Safari or IE to see what's loading on your site and how to work with and change the CSS and HTML.

2
  • I have my cache cleared and have the correct <h1 class="post-title entry-title">this is example title</h1> in the source. Any idea, if something else might be wrong ? – gurung Jan 9 '14 at 17:05
  • I'd ask in the Google Forums for Webmaster's Tools and the Structured Data Tool – markratledge Jan 9 '14 at 17:10
0

Got this fixed. I sought for help here in webmaster-forums and took a hint from an article here. The thing that I was missing was that the entire mark-up must be within within a class named hentry.

My title was outside the hentry class so google-bot was not able to extract the structured data properly. All credits to @markratledge for putting me in right direction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.