0

I have a simple website on wordpress (latest version), assume example.org.

I wanna have the user posts at something like example.org/blog/username/posttitle.

So I need some levels: 1) example.org/blog (main blog page) 2) example.org/blog/username (username archive page) 3) example.org/blog/username/posttitle (single post page)

I've seen a lot of old solutions that are mainly the same, but even if i set the permalink structure as /blog/%author%/%postname% or simply /blog/%postname% it doesn't work.

I mean, it works, but when you visit a right generated url I get a 404.

Solutions? Cheers,

  • Do you have installed a Multisite (network) version of WordPress? – bueltge Jan 8 '14 at 15:11
  • Nope, i found that it was because i've also set the base category to 'blog' and it collides with the permalink structure. It works now. Thanks! – mircobabini Jan 8 '14 at 15:17
  • Yes, Now I have understand the question right. I have read, that you will remove the blog slug. – bueltge Jan 8 '14 at 15:22
0

Try this in your premalink setting page: Use Custom structure and put in this /blog/%author%/%postname%/ into the field. That should do the trick.

  • Are you sure you read the full post? I cite myself: I've seen a lot of old solutions that are mainly the same, but even if i set the permalink structure as /blog/%author%/%postname% or simply /blog/%postname% it doesn't work. I mean, it works, but when you visit a right generated url I get a 404.. Thanks anyway, but it doesn't work anymore. – mircobabini Jan 8 '14 at 15:06
  • I tested it out on my blog, and it worked. My WP version is 3.8 – Suthan Bala Jan 8 '14 at 15:13
  • What do you mean a "right generated url" – Suthan Bala Jan 8 '14 at 15:13
  • I mean that the url is well done, accordingly with the permalink structure, but it falls in a 404. – mircobabini Jan 8 '14 at 15:15
  • Damn, i just found that it was because of i've set the base category to 'blog', it collides. My fault, it works. – mircobabini Jan 8 '14 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.