No matter what I do, I can't seem to get the NextGen plugin check to work. The plugin used to work but now won't load at all. I get this error on the plugin check:

Check theme compatibility Missing the call to in your theme

I have looked on the net and came up with this thread:


And added the:

  1. Add <?php wp_head(); ?> to your "header.php" right before </head>

  2. Add <?php wp_footer(); ?> to your "footer.php" right before </body>

as it stated in the thread. However, the plugin check still gives the error above (and consequently will not work -- it won't work anywhere on the site).

Does anyone have any suggestions on what to try next? The site I am supporting is http://cdnsba.org/ and you can see a big white space on the front left where the slideshow used to work perfectly.

I have a hunch that something is clashing with jQuery since it looks like the "Featured" section on the right doesn't scroll anymore either...



1 Answer 1


The latest release updates the jquery and some plugins had issues with that, you can always upload the older version in the wp-includes directory.

I took a sneak peek in the code and the following snippet should be the culprit.

function ngg_ajax_test_head_footer() {

// Build the url to call, NOTE: uses home_url and thus requires WordPress 3.0
$url = add_query_arg( array( 'test-head' => '', 'test-footer' => '' ), home_url() );
// Perform the HTTP GET ignoring SSL errors
$response = wp_remote_get( $url, array( 'sslverify' => false ) );
// Grab the response code and make sure the request was sucessful
$code = (int) wp_remote_retrieve_response_code( $response );
if ( $code == 200 ) {
    global $head_footer_errors;
    $head_footer_errors = array();

    // Strip all tabs, line feeds, carriage returns and spaces
    $html = preg_replace( '/[\t\r\n\s]/', '', wp_remote_retrieve_body( $response ) );

    // Check to see if we found the existence of wp_head
    if ( ! strstr( $html, '<!--wp_head-->' ) )
        die('Missing the call to <?php wp_head(); ?> in your theme');
    // Check to see if we found the existence of wp_footer
    if ( ! strstr( $html, '<!--wp_footer-->' ) )
        die('Missing the call to <?php wp_footer(); ?> in your theme');

This snippet loads your homepage body and checks if the wp_head and wp_footer are there. As you said you added these so that shouldnt be the problem. What I find strange is that you are missing a part of the die message, the wp_footer or wp_header parts.

As far as i can Tell it looks for < ! - - wp_head - - > (the comment) and not the actual code, the comments dont seem to be shown in your code did you add those?

  • I am using the "use google libraries" plugin to use them from Google. I even disabled that plugin and it didn't make any difference...
    – adamf
    Mar 24, 2011 at 11:07
  • Is there an easy way to tell how many jquery scripts are loading and what versions they are?
    – adamf
    Mar 24, 2011 at 18:31
  • I tried "downgrading" jquery but it didn't seem to matter. I wonder if there is something wrong with the edits made to the theme?
    – adamf
    Mar 25, 2011 at 0:57
  • Not sure what call you would be missing, did you try turning on debugging mode in wp-config see if you can get more information from that.
    – Patriek
    Mar 25, 2011 at 18:04
  • I got it to finally recognize the wp_head (w3 total cache was wiping out the comment). However, while the plugin validates, it still doesn't work. I have a feeling it is some sort of conflict with the theme jquery or something that is going on.
    – adamf
    Mar 30, 2011 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.