1

I manage a large multi site Wordpress installation with about 300 hundred users and blogs. The server is blocked from making internet requests, so I have defined a proxy service in wp-config.php ( WP_PROXY_HOST and WP_PROXY_PORT )

A few weeks ago, I upgraded to version 3.8. Things seemed to go well, but almost immediately I noticed that the admin panel was a bit slower.

Now that the users are back from vacation, they are starting to complain that the admin panel is intermittently slow. Sometimes it's quick and responsive, sometimes it takes 20,30,or 60 seconds for an edit-page page to load.

Unfortunately, I don't have the freedom to uninstall or reinstall the update without planning downtime and giving the organization notice.

Is there a way I can diagnose the problem ? Any plugins or log files that I should be looking at ? error_log and access_log seem pretty normal.

Occasionally, when editing a page, users see this errror :

Connection Lost. Saving has been disabled until you're reconnected we're backing up this post in your browser just in case.

Connection Lost. Saving has been disabled until you're reconnected we're backing up this post in your browser just in case.

If I use Chrome's developer tools->Network tab, I can't see much info other than that the post.php page is taking forever to load.

slow network page load

Could the proxy server be contributing to this problem ? How can I get to the bottom of it?

Thanks

  • FWIW, I'm having similar issues. However my multisite is on a server that doesn't use a proxy. I'm curious to what you find out...my investigations haven't turned up much. – NW Tech Jan 7 '14 at 19:18
  • Try to use this plugin to find "bad guy" - wordpress.org/plugins/p3-profiler – NetWeight Company Apr 10 '14 at 2:55
  • Maybe a problem with DB queries. You can check this with the plugin Debug Objects. wordpress.org/plugins/debug-objects – bueltge Jun 17 '14 at 11:11
  • I have a very large WP deployment internally. I had a lot of issues with 3.7 and 3.8 with a lot of ssl calls to wordpress.org (which I couldn't fix because I don't own proxy). 3.9 helped a bit because they reduced timeouts and some of the requirement calls. – STing Jul 22 '14 at 2:57
0

Tried all these:

  • Default theme
  • Renamed plugins folder
  • Deleted .htaccess
  • Restarted server

Nothing worked but finally this command made it work:

mysqlcheck -u db-username -p db-name --repair --databases

| improve this answer | |
  • What does that command do? Does it repair the database? – Christine Cooper May 17 '14 at 15:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.