1

Whenever I try to activate my custom built theme on the clients server, the website returns a '500 - Internal Server Error'.

enter image description here

The theme is working fine on my local machine, MAMP on my mac. I dont even know where to begin to solve this problem!

As far as I am aware, the wordpress is a fresh install and I have no plugins that are activated.

Edit: As requested, here is the structure of my theme:

> theme-folder
  - 404.php
  > assets
    > css
    > font
    > images
    > js
    > sequence
  - category-food-and-baking.php
  - comments.php
  - footer.php
  - front-page.php
  - functions.php
  - header.php
  - index.php
  - page.php
  - sidebar.php
  - single-default.php
  - single-food-and-baking.php
  - single.php
  - style.css

And the first section of my CSS is:

/*
Theme Name: OonaghsKitchen
Theme URI: http://www.hknudsen.co.uk
Author:H Knudsen
Author URI: http://www.hknudsen.co.uk
Description: The theme for Oonaghs Kitchen
Version: 1
License: GNU General Public License v2 or later
License URI: http://www.gnu.org/licenses/gpl-2.0.html
Tags: OonaghsKitchen

*/

closed as off-topic by Wyck, fuxia Dec 24 '13 at 22:54

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • Did you check your error logs? – birgire Dec 24 '13 at 15:54
  • Just to be clear, when you select a different theme, the issue is resolved? Can you share the file structure of your custom theme, and the head of your CSS file? – Sampson Dec 24 '13 at 15:59
  • I'm struggling to locate the logs! I have never installed wordpress on a windows server before :/ – user1636130 Dec 24 '13 at 15:59
  • Yes. The issue is resolved when I activate the 2013 default theme. I will update my post with the requested files in a second. – user1636130 Dec 24 '13 at 16:00
  • 1
    If you are on the dedicated server then check the apache/httpd/php log file. I am sure there you will find the reason of 500 error. If you are on the shared server enable the WP debug mode then activate the theme if you are not getting the error then you can follow the below steps as well: - Create sub directory in your root - Do another WP fresh installation and activate the theme no other plugins. – Manish Dec 24 '13 at 16:08
0

You start by enabling WP debugging.

Wanted to add that a 500 error is typically a httpd server issue, either configuration or (more likely in this case) doing something in WP that you shouldnt, e.g. modifying http headers incorrectly.

  • I have set WP_DEBUG to true in the config, but nothing is being output to the page. The image in my post is the only error i can see. – user1636130 Dec 24 '13 at 15:57
  • I would enable WP_DEBUG and WP_DEBUG_LOG at a minimum so you can see what WP is doing via debug log file - /wp-content/debug.log – user42826 Dec 24 '13 at 16:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.