A client website has recently had the issue of a blank admin but the menu is showing. No admin pages appears at all. Just plain ol white, nothing showing in the source code either. Front end of the site works fine.

Client states that no plugins, themes or WP Core has been updated.

I installed a copy of the site on MAMP (local machine) and the admin works fine. I then installed the site on a server online but the same issue happens.

I have tried the following:

  • Deleted all plugins
  • Renamed the plugins folder
  • Deleted theme, left default theme
  • Deleted WP files and used latest WP files

None of the above made any difference.

Can anyone help out with some ideas what could cause this issue? I know that you have no backend access yourselves but any tips would help. The site is: letitgrowhydro.co.uk.

  • I actually am not accustomed to this problem, but you can also try something like: deleting the site's .htaccesss file (it'll be created again automatically); if the site had any cacheing plugin, you can check the db for some cacheing things, and can del/disable those cacheing things manually to get access into the functional admin panel. I'm not sure I'm giving you THE way, but I'm suggesting to try something like this. – Mayeenul Islam Dec 20 '13 at 16:30
  • 2
    have you enabled debugging? – Milo Dec 20 '13 at 16:33
  • I tried deleting the .htaccess file but still no luck. – Huw Rowlands Dec 20 '13 at 19:28
  • Can you provide a screen shot of the admin screen and menu? I need a picture to figure out what component is the problem. I definitely recommend turning on debugging as Milo suggested; and post any suspicious error messages. – user42826 Dec 21 '13 at 7:17
  • Here's the screenshot: postimg.org/image/ovjsuittx This appears no matter which menu item is clicked upon except the WPECommerce sections. There are some errors when enabling debug. One such error is: Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/hydro/public_html/wp-includes/functions.php on line 3551 – Huw Rowlands Dec 22 '13 at 9:42

protected by Community Jun 24 '14 at 12:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.