0

WordPress site is configured in IIS for which i have updated the permalink structure to be www.testing.com/company, www.testing.com/products, etc...

I do have another site which was created in the IIS, but the URL of the site is print.testing.com/printing, but whenever i access this print.testing.com site, WordPress site is getting connected, but not the actual site. does anyone know know to update the permalink structure / the host header so that the site redirects works correctly?

migrated from stackoverflow.com Dec 18 '13 at 1:04

This question came from our site for professional and enthusiast programmers.

0

it says when you answer to avoid asking for clarification, but how else do you let someone know more info is needed? I tried to pull up both urls, the subdomain by itself, and with the additional "printing" folder on the end, both pull up nil.

There are a couple ways to do it, but first of all it should be mentioned that whenever you plan to make permalink changes, you need to always have a backup of your database (and a way to restore it when 'not' logged in to the site, whether it's phpMyAdmin, or some other host-owned database tool).

So, if you have a backup, you can (should) restore your database to before the change, then troubleshoot and find out what went wrong. (1) Do you have mod_rewrite turned on via .htaccess, or some other php configuration tool? (2) Is your .htaccess file WRITEABLE BY WORDPRESS?? (log onto your host's file manager and check your security/permissions/chmod settings ) If your .htaccess file was not editable when you changed your permalinks, you can edit them manually and upload the new file via ftp. There are instructions here: http://wordpress.org/support/topic/page-permalinks-do-not-work-15 (3) The subdomain 'is' working, because I can type it in the address bar, view source the page that comes up, copy the address to the imported CSS files, paste that at the end of the subdomain url, and view that CSS file...so the subdomain is working, that is not the issue. It is likely a permissions issue somewhere. (4) do you 'have' a wordpress install at that location? (the subdomain) Did you move the site from somewhere? You can change those settings in your wp-config.php file. If this doesn't help, try to be very specific when posting: i.e. I went here (to this url) and got this (exact output) ...

Any info as to where 'what' is stored and 'what' generates 'what' should be found here: where is permalink info stored in database?

Hope that helps. Donna

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.