0

I have a new web server at the Hetzner EX60.

With this new site I have many problems. First of all I need to say that I have problems with default theme and without any plugins. I tried to resolve them abuot a month. All of these problems are related to admin area. Fail to load jQuery and the same things. I already added

define('CONCATENATE_SCRIPTS', false);

to config.php file. And now I have problems only with post-new.php and post.php?post=##&action=edit pages. And only when I try to edit or add new post. With adding/editing pages I haven't any problems.

What's the problem on those pages? I have missing visual editor. The page isn't loaded to the bottom. 'Upload meadia' button not works. All that is related to js and in particular with jQuery.

I resolved a part of this problem with installing W3-Total-Cache. Also I added these lines to config.php

define('AUTOSAVE_INTERVAL', 300 );
define('WP_POST_REVISIONS', false );

Now sometimes I have visual editor and full loaded page and sometimes not. If have problems I purge cache and refresh the page. From 5 page loads I have a case when all is great. It is very uncomfortably and awkward.

Because W3-Total-Cache helped me partially to resolve my problem, I make conclusion that I have bad server config and something with cache. But my friends that are also located with me at this server and using other CMS have no problems.

About server: At the server front-end is nginx and at the backend is Apache. How to make best configuration for it? Currently is installed:

bz2.so
calendar.so
cgi-fcgi.so
соre.so
ctype.so
curl.so
date.so
dcm.so
ereg.so
exif.so
fileinfc.so
filter.so
ftp.so
gd.so
gecip.so
gettext.so
gmp.so
hash.so
iconv.so
imagick.so
json.so
libxml.so
mbstring.so
mcrypt.so
memcached.so
mhash.so
mysql.so
mysqli.so
cpenssl.so
pcntl.so
pcre.so
pdo.so
pdo_mysql.so
pdo_sqlite.so
phar.so
readline.so
reflection.so
session.so
shmcp.so
filter.so
ftp.so
gd.so
gecip.so
gettext.so
gmp.so
hash.so
iconv.so
imagick.so
json.so
libxml.so
mbstring.so
mcrypt.so
memcached.so
mhash.so
mysql.so
mysqli.so
cpenssl.so
pcntl.so
pcre.so
pdo.so
pdo_mysql.so
pdo_sqlite.so
phar.so
readline.so
reflection.so
session.so
shmcp.so
simplexml.so
sockets.so
spl.so
sqlite3.so
standard.so
tokenizer.so
wddx.so
xcache.so
xml.so
xmlreader.so 
xmlrpc.so
xmlwriter.so 
xsl.so 
zip.so 
zlib.so
  • Do you have debugging information? What do your server logs say? Is there useful information in the browser console? – s_ha_dum Dec 15 '13 at 16:19
  • @s_ha_dum in logs are no errors. In browser is nothing helpfull too. Only jQuery errors and warning. But such errors and warnings are everywhere at the admin part. Something like: event.returnValue is deprecated. Please use the standard event.preventDefault() instead. Uncaught TypeError: Cannot call method 'getCurrent' of undefined – okonik Dec 15 '13 at 20:47
  • 1
    Script issues admin-side are common because of mod_security, I would check if it is running and its logs. – Rarst Dec 15 '13 at 21:27
  • @Rarst Here's my phpinfo page dl.dropboxusercontent.com/u/15839134/phpinfo.htm Or should I give you the site URL and some of login to check it inside? – okonik Dec 15 '13 at 23:57
  • Bad idea to give credentials to random person on the Internet. Please note that if it's so localized it can't be figured out without hands on access you probably need hosting support (if any) or hired professional looking at it. – Rarst Dec 16 '13 at 9:11
0

So, I need to say that now is all ok. I can't belive this :') For about a month I asked a lot of people and nobody didn't know what's the problem. It was cause we had bad nginx config. Now nginx is turned off for a some time. Apache is ok. Thank to s_ha_dum, thanks to Rarst

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.