Am working on my WordPress site. I changed font color of my site then I have refreshed my page but it redirects to wp-admin/install.php.

What can I do now? How can I get access to my site?

  • 1
    How did you change the font color and which file did u edit ? Did you in any way touch wp-config.php or the database ? Dec 13, 2013 at 8:13
  • And, where are you working, on a localhost, or a remote server. Please edit your question with more details to get a good detail answer. Dec 13, 2013 at 8:31
  • sorry! am working in remote server i haven't touch the wp-config file Dec 13, 2013 at 10:10
  • How did you change a font color? Did you upload a new copy of a CSS file or what? Strains credibility to think a CSS edit would dump a site.
    – jdm2112
    Jul 25, 2014 at 2:41

9 Answers 9


I've had this problem. I contacted my hosting provider and they told me it happened because I exceeded maximum queries per hour limit and therefore access to the database was temporarily locked, so WP couldn't read from it.

  • guess I'm having the exact same thing. Tried to login to phpMyAdmin and server returned a 500
    – Niko
    Mar 3, 2017 at 10:46

Open your codebase/setup through FTP or so.

  • Check the database name, username, password and table prefix in the wp-config.php file.
  • Check if the wp-config.php file exist and file has not been misspelled in the name or the extension.

Reference: http://codex.wordpress.org/Editing_wp-config.php


After restarting my machine my wordpress started redirecting to install. The database reported that the tables for wordpress 'did not exist' when viewed through phpMyAdmin. Shutting down the webserver, then restarting the mySQL server fixed the issue on my system.

Please try shutting down your webserver (gracefully), then restart mySQL.


Try looking at wp_options table in phpMyAdmin and hitting "Optimize table". Worked on one of my sites that had this exact issue (though not sure what caused it initially).


The issue is within wp-config.php file. You have to double check the $table_prefix field and make sure that it corresponds to table prefixes in your actual database.

Example: If in the database your tables look like wp_website_year_comments in your wp_config.php it should look like this:

* WordPress Database Table prefix.
* You can have multiple installations in one database if you give each
* a unique prefix. Only numbers, letters, and underscores please!
$table_prefix = 'wp_website_year_';

I also experienced this problem and finally realized that the Jetpack plugin installed along with Wordpress is the root cause. It prevents bruteforce attack and enhance security so after about 10 REST calls to the server, it automatically blocks all requests by redirecting to install.php. Deactivating Jetpack solved my problem.


Some fixes that always work:

  1. CHECK wp-config

    • DB Logins must be updated
  2. Check Prefix in wp-config Sometimes the prefix is wrong like wp_ or any other. Check your database and correct it.

  3. Check .htaccess file Try putting default wordpress htaccess file

  4. Check wp-config file name Sometimes people edit wp-config-sample file instead. You have to edit wp-config file.

  • I wouldn't add an email to contact you. Jan 30, 2019 at 13:33

@Izzy Hegazy solution worked in my case. I totally forgot I had changed the table prefix on the old installation. Meanwhile, on the new installation, I used the default wp_ table prefix.


  1. In the case of a migration; ensure your table prefix on the old installation is same on the new installation.

  2. Delete the wp-config-sample.php file.

  3. Check if wp-config.php exists

  4. Check the database connection details and confirmed they're pointed to the right database. (username & password)

  5. Try repairing the database tables using PHPmyadmin. At times database tables get corrupted and cause errors.

These are always the fix in most cases.


This happens due to the following issues:

  1. Missing Files
  2. Database Connection Details Problem
  3. Site URL Issue
  4. .htaccess File Issue
  5. Webserver Failure
  6. Resources Blocked by Plugin
  7. Query Limit Exceeded
  8. Insufficient Database Privileges
  9. PHP Extensions

Reference: https://www.scratchcode.io/wordpress-keeps-redirecting-to-wp-admin-install-php/

Not the answer you're looking for? Browse other questions tagged or ask your own question.