I had thumbnails set up and working perfectly on my site. However, I wanted to change the size and did so through the functions.php file (although I see this is now an option in Settings -> Media). I then used the plugin Regen. Thumbnails. It went through all the images and seemed to be successful. However, this has now broken all of my thumbnails. I can see it did not create new images in the uploads folder (just the original 150x150px thumbnails). All the links through to thumbnails now just link through to the full size of the image. If I upload a new image, a thumbnail will not be generated.

I've restored the thumbnail settings back to the original settings, no luck (also tried regenerating them at the original size even though these are still present in the uploads folder).

Any ideas?!

  • Which plugin exactly had you used (as in link to it)? Were there any errors? – Rarst Dec 13 '13 at 16:00
  • Ah, totally missed you comment! The plugin is called Regenerate Thumbnails: wordpress.org/plugins/regenerate-thumbnails. No errors shown, it runs through all the images, says they were all successful with no errors but I can't even find the new images it's supposedly made. – lotech Dec 16 '13 at 9:54
  • OK, I've narrowed it down to a permissions issue by running a local copy and giving global 777 permissions and it worked fine. Now I just need to figure out how I can grant it the correct permissions to generate thumbnails in the future on the live server. – lotech Dec 16 '13 at 10:39
  • Nope, I'm totally stumped now. Just check a previous website I built and the permissions are exactly the same and it works fine under the same environment. Weird. – lotech Dec 16 '13 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.