I'm trying to install Thesis on my blog, and I'm having an issue that's caused by the theme that's currently active, which is Structure by Okay Themes.

This theme created a static home page when I installed it, but not in the way recommended by the WordPress docs.

When I activate Thesis, the home page returns an empty HTML doc.

I'm a developer, so I'm comfortable monkeying around behind the scenes, but I'm not sure where to start. Did the theme install a custom PHP file and set it as the home page?

Any suggestions would be much appreciated.


The options table has a current_theme value that names Structure:

| option_id | option_name   | option_value | autoload |
|       158 | current_theme | Structure    | yes      |
  • What have you done to remove the "Structure" theme? Or how are you trying to uninstall it? Have you tried just deleting the files via FTP? – s_ha_dum Dec 1 '13 at 17:47
  • So far all I've done is deactivate it. I tried activating both Thesis and the 2013 theme, and in both cases http://aspirecode.com just returns an empty HTML file. – Josh Earl Dec 1 '13 at 18:26
  • Did you try changing the Settings > Reading option for Front page displays to Your latest posts so thesis will not use a static page? – Charles Clarkson Dec 1 '13 at 20:30

It sounds like the theme is hanging when you try to disable it.

Physically remove the theme. Login over FTP and delete or rename the theme directory. If that doesn't work this will take a lot of debugging. WordPress will notice that the active theme is gone/broken and load a default theme.

I tell you the following with great caution. Try this only if no other options are available, and just before you cash out and reinstall.

You can also try manually switching themes. Search the $wpdb->options table for current_theme in the option_name column and change the associated option_value to "Twenty Thirteen" (I am assuming that theme is on your system"). Do the same with the template and stylesheet values but change them to "twentythirteen". Edit carefully. You can break things. That will force a theme switch, or it does when I try.

As with any database edit, back things up thoroughly first. This has been tested but not thoroughly. Do not ignore the "back things up" part. If you don't know how to back up the database (not the PHP files), then stop.

I don't know what else your theme might have done, so no guarantees. The fact that renaming the directory did not help gives me pause. There will still be entries in the database that should probably be cleaned up.

  • Renaming the Structure theme folder produced the same result. The setup for this theme involves a data import--could that have set up a different home page? – Josh Earl Dec 1 '13 at 18:58
  • Argghhh... try looking through the $wpdb->options table for referenced to the theme. Look for current_theme in the option_name column first. This could be painful. – s_ha_dum Dec 1 '13 at 19:08
  • I found the current_theme value, and it points to Structure. See update above. – Josh Earl Dec 1 '13 at 19:22
  • @JoshEarl : see the edit – s_ha_dum Dec 1 '13 at 20:19

I'm sure you have already checked this, but perhaps there is an active plugin which is referring to a file in that theme. I would suggest deactivating all plugins and then manually remove the theme. If you still have trouble you may need to repair/optimize the database.

  • Good thought--there was a plugin, but deactivating it didn't help. :( – Josh Earl Dec 2 '13 at 13:41

I'd try this: move the current wordpress installation folder aside and create a new installation of wordpress, bring your settings and files over as if you're migrating your site but don't bring the troublesome theme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.